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Note pour les utilisateurs Mac

Certains raccourcis claviers sont différents sous Mac de ceux utilisés sous Windows et Linux. Le
tableau ci-dessous donne quelques correspondances pour les instructions de ce guide. Pour une
liste plus détaillée, référez-vous a l'aide du logiciel.

Windows ou Linux Equivalent Mac Effet

Outils > Options LibreOffice > Préférences Acces aux options de paramétrage
Clic droit B +clic Ouvre un menu contextuel

Ctrl (Contréle) # (Commande) Utilisé avec d'autres touches

F5 Maj+38+F5 Ouvre le Navigateur

F11 F}+T Ouvre la fenétre Styles et formatage
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Introduction aux champs

Les champs sont trés utiles dans Writer. lls sont employés a des fins diverses :

* pour des données a modifier (la date du jour ou le nombre de pages) ;

* pour des données qui pourraient étre modifiées (le nom d'un produit ou d'un livre en cours
de rédaction) ;

* pour des séquences de numérotation définies par I'utilisateur ;

* pour des renvois automatiques ;

* pour du contenu conditionnel (mots ou paragraphes qui sont rendus visibles et imprimés
sous certaines conditions).

* pour des entrées d'index.

Ce chapitre aborde les champs couramment utilisés. Une description compléte des champs va
au-dela du but de ce guide. Les utilisateurs les plus avancés pourront toutefois se référer a I'Aide
du logiciel pour obtenir des renseignements complémentaires.

Les champs ont un arriére-plan grisé, a moins que vous n'ayez décoché l'option

Trame de fond des champs ou modifié la couleur de fond des champs dans la

sous-section LibreOffice — Apparence (menu Outils > Options). Cet arriére-plan
Astuce grisé n'apparait pas a l'impression ou a I'export PDF.

Pour désactiver rapidement l'arriere-plan grisé des champs, cliquez sur le menu
Affichage > Trame de fond des champs ou appuyez sur les touches Ctr/l+F8.

Entrée de champ facile et rapide

Vous pouvez insérer rapidement les entrées de champs les plus utilisées en cliquant sur le menu
Insertion > Champs. Choisissez alors le champ souhaité dans la liste (voir Figure 1).

Insertion Format Tableau ©Outils Fenétre Aide

Saut manuel... a
ﬂf'!'““Q’ Date
| Caractéres spéciaux... Heure
Marque de formatage b Numéro de page
. Nombre de pages
Section... ot pag
. Sujel
Hyperlien
=P Titre
En-téte b Auteur
Pied de page ’
Autres... Ctrl+F2

_ Notede bas de paae/de fin...
Figure 1. Insérer rapidement un champ.

Utiliser les propriétés du document pour gérer les informations
modifiables

La boite de dialogue Propriétés (du document) contient six onglets. Les informations des onglets
Général et Statistiques sont générées par le programme. D'autres informations, notamment le
nom de l'auteur dans l'onglet Général, dépendent des données d'identité saisies dans la
sous-section LibreOffice — Identité des Options (accessibles via le menu Outils > Options).
L'onglet Internet ne concerne que les documents HTML (Writer/Web). Les options de partage de
fichiers de l'onglet Sécurité sont abordées dans une autre section de ce guide.
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Les onglets Description et Propriétés personnalisées vous permettent de définir :

* Des métadonnées pour aider a classer, trier, stocker et récupérer des documents.
Certaines de ces métadonnées peuvent étre exportées vers leur équivalent pour les
documents HTML et PDF ; les champs qui n'‘ont pas d'équivalent dans ce type de
document ne seront pas exportés.

* Des informations modifiables. Vous pouvez stocker des données pour créer ultérieurement
un champ dans votre document. Par exemple : le titre du document, les coordonnées d'un
participant du projet ou le nom d'un produit, etc. Ce type d'information est susceptible d'étre
modifié.

Plus loin dans ce chapitre, nous verrons comment utiliser ces informations dans des champs. Vous
pouvez revenir a cette boite de dialogue a tout moment et modifier les informations saisies. Si
vous le faites, toutes les références a ces informations seront modifiées partout ou elles
apparaissent dans le document. Par exemple, dans I'onglet Description (voir Figure 2), il se peut
gue vous modifiez le champ Titre entre le moment de la production du brouillon et celui du
document final.

@ Propriétés de WG4014FR-TravaillerAvecLesChamps

Genéral Propriétés personnalisées| Internet Sécurité Statistiques
Titre Travailler avec les champs
Sujet
Mots-clés

Commentaires
Figure 2. L'onglet Description de la boite de dialogue Propriété du document.
Pour ouvrir la boite de dialogue Propriétés, cliquez sur le menu Fichier > Propriétés.

Dans l'onglet Propriétés personnalisées (voir Figure 3), vous pouvez stocker les informations qui
ne correspondent pas aux champs proposés dans les autres onglets de cette boite de dialogue :

Lorsque vous ouvrez l'onglet Propriétés personnalisées d'un nouveau document pour la
premiére fois, il devrait étre vide. Cependant, si le nouveau document est basé sur un modéle, il se
peut que cet onglet contienne des informations.

Cliquez sur le bouton Ajouter pour insérer une nouvelle rangée de boites dans lesquelles vous
pourrez saisir des propriétés personnalisées.

* La colonne Nom comprend une liste déroulante de choix typiques. Faites défiler cette liste
pour visualiser tous les choix possibles. Si aucun de ces choix ne vous convient, vous
pouvez saisir un nouveau nom dans la boite.

¢ Dans la colonne Type, vous pouvez choisir les options pour chaque champ : texte, date
heure, date, durée, numéro, oui ou non. Vous ne pouvez pas créer de nouveau type.

* Dans la colonne Valeur, saisissez ou sélectionnez ce que vous souhaitez voir apparaitre
dans votre document a l'endroit ou le champ sera utilisé. Les choix sont limités aux
données spécifiques des types (sélectionnés dans la colonne Type). Par exemple, si le
Type sélectionné est Date, la Valeur pour cette propriété sera limitée a une date.

* Pour supprimer une propriété personnalisée, cliquez sur le bouton Supprimer une
propriété a la fin de la rangée.
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Pour modifier le format de la valeur Date, cliquez sur le menu Outils > Options >
Paramétres linguistiques > Langues et changer les paramétres de langue.
Attention ! Ces modifications affecteront tous les documents, pas seulement le
document actif.

@ Propriétés de WG4014FR-TravaillerAvecLesChamps

Général Description Propriétés personnalisées |Internet Sécurité Statistiques

Astuce

Propriétés

Nom Type Valeur
Achevé a la date ¥ | |Date > | |o5/08/2013 - | =
Info 2 v | | Texte > | [xyxyxy =]
Info 3 * | |Texte = | Iyyyyyy z==]
Info 4 v | Texte s | |zzzzEZZ =

Figure 3. L'onglet Propriétés personnalisées de la boite de dialogue Propriétés du
document.

Utiliser d'autres champs pour gérer les informations
modifiables

Il est important de mettre a jour une information susceptible d'étre modifiée au cours d'un projet.
Par exemple, le nom d'un gestionnaire, d'un produit ou méme de votre entreprise tout entiére peut
étre changé juste avant que le document ne soit imprimé. Si vous avez inséré ces informations en
tant que champs, vous pouvez facilement les modifier a un seul endroit et tous les champs seront
automatiquement mis a jour dans votre document.

Writer propose plusieurs endroits pour stocker l'information référencée comme un champ. Nous
allons en examiner quelques-uns dans cette section.

Sept propriétés de document (Date, Heure, Numéro de page, Nombre de pages, Sujet, Titre et
Auteur) se trouvent dans le menu Insertion > Champs (voir Figure 1). Pour insérer I'un de ces
champs, cliqguez dessus dans le menu. Certains de ces champs prennent les informations depuis
la boite de dialogue Propriétés du document (voir Figure 2.)

D'autres informations sur le document se trouvent dans les onglets Info document et Document
de la boite de dialogue Champs (voir Figure 4 et Figure 5), accessible en cliquant sur le menu
Insertion > Champs > Autres ou en appuyant sur les touches Ctrl+F2. A noter que I'élément
Personnaliser dans la liste Type de champ de l'onglet Info document est basé sur l'onglet
Propriétés personnalisées de la boite de dialogue Propriétés du document (voir Figure 3).

Pour insérer I'un de ces champs, cliquez dessus dans la liste Type de champ, puis faites votre
choix parmi les éléments qui peuvent apparaitre dans les listes Sélection et Format. Pour finir,
cliquez sur le bouton Insérer.
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Document Renvois Fonctions Info document|Variables Base de données

Type de champ Sélectionner Format
Commentaires Auteur 31/12/99
Créé Heure 31/12/19%9

Derniéreimpression | [FETM 31 déc. 99
Durée d'édition 31déc. 1999
= 31. déc. 1999

Mots-clés 31décembre 1999

Numéro de révision 31. décembre 1999
» Personnaliser

: ven. 31 déc. 99
?:?r'eet ven. 31/déc. 99
ven. 31 décembre 1999
vendredi 31 décembre 1992
12-31
99-12-31
1999-12-31
12/99
31/déc.
décembre

PR B N B

[] Contenu fixe

| Insérer J Eermer Aide

Figure 4. Insérer un champ de date modifiable via I'onglet Info document de la
boite de dialogue Champs.

Documenkt|Renvois Fonctions Info document Variables Base de données

Type de champ Sélectionner Formak

Chapitre Chemin

Date Chemin/Mom de fichier
Expéditeur Nom de fFichier

Heure Nom de fichier sans extension
Modéles

Page

Statistiques

Utilisateur

Figure 5. Insérer un champ Nom de fichier via I'onglet Document de la boite de
dialogue Champs.

Certains éléments sont basés sur la sous-section LibreOffice — Données d'identité de la boite de
dialogue Options (accessible via le menu Outils > Options). Assurez-vous donc que les
informations mentionnées sont correctes. Pour plus d'informations sur les données d'identité,
référez-vous au chapitre 2, Paramétrer Writer, de ce guide.

Bien que ces champs soient souvent utilisés pour gérer des informations
modifiables, vous pouvez fixer leur contenu en cochant I'option Contenu fixe (voir

Astuce Figure 4) lorsque vous insérez le champ. Si nécessaire, vous pourrez revenir
ultérieurement a cette boite de dialogue pour décocher cette option et rendre ainsi
le champ a nouveau variable.
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Utiliser les AutoTextes pour insérer des champs courants

Si vous utilisez fréequemment les mémes champs, vous souhaiterez sans doute une fagon rapide et
facile de les insérer. Les AutoTextes sont la solution. Suivez ces étapes pour définir une entrée
d'AutoTexte comme un champ :

1) Insérez un champ dans votre document, comme décrit précédemment.

2) Sélectionnez le champ et cliquez ensuite sur le menu Edition > AutoTexte ou appuyez sur
les touches Ctrl+F3 de votre clavier.

3) Dans la boite de dialogue AutoTexte (voir Figure 6), choisissez la catégorie dans laquelle
cette nouvelle entrée sera enregistrée (dans cet exemple, ce sera la catégorie Mes
AutoTextes), saisissez le nom de I'entrée et modifiez le raccourci proposé si nécessaire.

4) Cliguez sur le bouton AutoTexte pour afficher une liste déroulante. Cliquez ensuite sur
Nouveau (a noter que cette option n'apparaitra pas si vous n'‘avez pas choisi de catégorie
et saisi un nom pour l'entrée). Ne cliquez surtout pas sur l'option Nouveau (texte
seulement), car cette entrée deviendrait du texte brut et non un champ. Cliquez sur le
bouton Fermer pour fermer la boite de dialogue AutoTexte.

5) Maintenant, si vous souhaitez insérer ce champ a la position du curseur, saisissez le
raccourci et appuyez ensuite sur la touche F3 de votre clavier.

Py

AutoTexte

Insérer
& Lors de la saisie, afficher le nom complet sous Forme d'infobulle SDESre

i : Fermer
Nom étape Raccourci |e

rofessionnelles (85 x 50) : Aide

» Uniquement pour les modéles

MNouveau (texte seulement)

Ilmporter...

Enregistrer des liens relatifs
| Dans le systéme de Fichiers ["] Surlnternet & Afficher l'apercu

Figure 6. Créer une nouvelle entrée d'AutoTexte.

Définir des séquences de humérotation personnalisées

Il vous arrivera peut-étre d'avoir besoin de définir une séquence de numérotation personnalisée,
par exemple pour Il'utiliser dans des situations ol vous ne souhaitez pas toujours de numérotation
au début d'un paragraphe ou lorsque vous souhaitez avoir plus de contrdle sur la numérotation
gue celui autorisé par par défaut.

Cette section décrit comment créer et utiliser une séquence de numérotation en utilisant le champ
Séquence.

Créer une séquence de numérotation variable

Pour créer une séquence de numérotation variable utilisant les chiffres arabes (1 2 3) :
1) Placez le curseur de la souris dans un paragraphe vierge du document.

2) Cliguez sur le menu Insertion > Champs > Autres ou appuyez sur les touches Ctrl+F2 de
votre clavier. Dans la boite de dialogue Champs, cliquez sur I'ongle Variables.

3) Dans la liste Type de champ, sélectionnez Séquence. Dans la liste Format, sélectionnez
Arabe (1 2 3). Saisissez Etape dans le champ Nom.

10 Travailler avec les champs



Documenkt Renvois Fonctions|Info document|Variables Base de données

Type de champ seélection Format

DéFfinir une variable I /ccC

AfFicher la variable Figure abc

Champ DDE llustration AL AA L AAA

Insérer une formule Tableau a. aa.. aaa

Champ de saisie Texte Romain (111111)

Romain (i i i) -
DéFinir une variable de page
Afficher la variable de page A, B, .., A3, AB, ... (bg)

Champ d'utilisateur a, b, .. aa, ab,...(bg)

A, B, .., A3, B6, ... (bg)
a,b,.. aa, 66,..(bg) =

Numeérotation par chapitre
Niveau Aucun -
Séparateur
Nom Valeur

Etape

Insérer Fermer Aide

Figure 7. Définir une séquence variable.

4) Cliquez sur le bouton Insérer. Le nom de la variable (Etape) apparait désormais dans la
liste Sélection et un champ numéroté (affichant le nombre 1) apparait dans votre
document. La boite de dialogue Champs reste ouverte, vous avez donc besoin de la
déplacer afin de visualiser le champ dans le document.

5) Si vous cliquez plusieurs fois sur le bouton Insérer de la boite de dialogue Champs, les
nombres 2, 3, 4 et ainsi de suite, apparaitront dans le document.

Si vous souhaitez redémarrer cette séquence de numérotation a 1, de fagcon a ce que vous
puissiez utiliser plusieurs fois le méme nom de séquence dans votre document (par exemple, pour
démarrer chaque ensemble d'instructions). Vous devez insérer un nouveau champ portant le
méme nom, tout en contraignant Writer a forcer la valeur a 1.

1) Ouvrez la boite de dialogue Champs sur l'onglet Variables. Assurez-vous que le nom de la
variable Etape s'affiche dans le champ Nom.

2) Dans le champ Valeur, saisissez 1 comme montré en Figure 8. Cliquez sur le bouton
Insérer. La numérotation redémarre, mais les autres numéros restent corrects.

3) Pour poursuivre l'incrémentation de la numérotation (la prochaine valeur sera donc 2), vous
devez effacer le contenu du champ Valeur. Insérez ensuite les autres numéros.

Définir des séquences de numérotation personnalisées 11



Document Renvois Fonctions| Info document Variables Base de données

Type de champ Sélection Format
Deéfinir une variable Dessin ABC
Afficher la variable Etape WEYYS
Champ DDE Figure ALAA L AAA
Insérer une Formule Illustration a..aa..aaa
Champ de saisie Tableau Romain (11111)
Texte Romain (i i iii) -
Définir une variable de page Arabe (123)
Afficher la variable de page A, B, .., Aa, AB, ... (bg)
Champ d'utilisateur a, b, ., aa, ab, ... (bg)
A, B, .., Aa, Bb, ... (bg)
a,b,..,aa, 66,..(bg) -
Numérotation par chapitre
Niveau Aucun -
Séparakeur
Nom Valeur
Etape 1

Insérer Fermer Aide

Figure 8. Définir un champ pour redémarrer l'incrémentation de la numérotation.

Utiliser un AutoTexte pour insérer une séquence de numérotation

Il est plus facile de ne pas passer par toutes ces étapes a chaque fois que vous voudrez insérer un
numéro d'étape. A la place, vous pouvez créer deux entrées d'AutoTexte :

1) une entrée appelée Etapel créée a partir de la variable Etape dont la valeur est 1 ;

2) une entrée appelée EtapeSuivante créée a partir de la variable Etape sans définir de
valeur.

Insérez ensuite les champs de la méme fagcon que vous le feriez pour n'importe quel autre
AutoTexte. Pour recommencer la numérotation a 1, insérez I'AutoTexte Etapel, puis continuez
avec |'AutoTexte EtapeSuivante. Pour plus d'informations sur lutilisation des AutoTextes,
référez-vous a la section Uliliser les AutoTextes pour insérer des champs courants en page 10.

Vous pouvez créer des champs similaires pour les sous étapes ou d'autres séquences que vous
souhaitez numéroter avec des lettres (a, b, c), des chiffres romains (i, ii, iii) ou encore d'autres
séquences. Dans la boite de dialogue Champs, choisissez le format requis dans la liste Format
lorsque vous créez les codes de champ.

Si une variable définie par I'utilisateur n'est pas utilisée dans le document, l'icbne

il prés du champ Valeur est active. Vous pouvez supprimer la variable en

Astuce cliguant sur cette icbne. Pour supprimer une variable utilisée dans le document
actif, supprimez d'abord dans le document tous les champs utilisant cette variable
(ou convertissez-les toutes en texte comme décrit en page 19) et supprimez
ensuite la variable de la liste.
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Utiliser les renvois automatiques

Si vous saisissez des renvois a d'autres parties du document, ces références peuvent facilement
devenir obsolétes si vous modifiez un titre, ajoutez ou supprimez des illustrations ou réorganisez le
contenu. Remplacez toutes les références par des renvois automatiques et, lorsque vous

actualiserez les champs, toutes les références seront actualisées automatiquement pour afficher le
contenu actif et/ou les numéros de page.

Certaines personnes utilisent la fonction Hyperlien de Writer pour réaliser des

renvois, mais elle a le désavantage majeur que le texte visible de I'hyperlien n'est

pas modifié si vous modifiez I'élément auquel il est lié. Pour cette raison, il est
Astuce conseillé d'utiliser les renvois dans la plupart des situations.

Il y a une exception a cette régle lorsque vous créez un document qui doit étre
enregistré en HTML, les renvois ne deviennent pas des hyperliens dans un
document HTML.

L'onglet Renvois de la boite de dialogue Champs (voir Figure 9) répertorie quelques éléments
comme des titres, des paragraphes et des repéres de texte. Si des légendes de figures ou de
tableaux, des séquences variables ou d'autres éléments ont été définis dans le document, leur
type apparait également dans la liste.

Document Renvois |Fonctions Info document Variables Base de données

Typede champ Sélection
Définir une référence Définir des séquences de numérotation personnalisées =
Insérer une référence Créer une séquence de numérotation variable |
Titres Utiliser un AutoTexte pour insérer un séquence de numérota| |
Paragraphes numérotés Utiliser les renvois automatiques L
Figure Insérer un renvoi
Reperes de texte Formats disponibles
Préparer les éléments cibles pour le renvoi
iliser | . | -
[{ | 1]
Insérer une référence a Nom
Définir des séquences de numeér
Chapitre
Référence Valeur
Supra/infra
D'aprés le style de page
NMombre

NMumero (sans contexkte)
Numeéro (contexte complet)

Insérer Eermer Aide

Figure 9. L'onglet Renvois de la boite de dialogue Champs.

Insérer un renvoi

Pour insérer un renvoi a un titre, une figure ou d'autres éléments affichés dans l'onglet Renvois :

1) Dans le document, placez le curseur a l'endroit ou vous souhaitez que le renvoi
apparaisse.

2) Si la boite de dialogue Champs n'est pas ouverte, cliquez sur le menu Insertion >
Champs ou appuyez sur les touches Ctrl+F2 de votre clavier. Dans l'onglet Renvois (voir
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3)
4)

5)

6)

Figure 9), cliguez dans la liste Type sur le type d'élément que vous souhaitez référencer
(par exemple, Titre ou Figure).

Vous pouvez laisser cette boite de dialogue ouverte pendant que vous insérez les renvois.
Cliquez sur les éléments requis dans la liste Sélection qui affiche automatiquement les

entrées créées (par exemple, les titres du document), ainsi que les références définies par
I'utilisateur (par exemple, les repéres de texte).

Dans la liste Insérer une référence a, choisissez le type de référence que vous souhaitez.
Les possibilités varient en fonction de I'élément référencé.

Pour les titres, vous choisirez probablement Référence (pour insérer le texte complet du
titre) ou Page (pour insérer le numéro de page sur laquelle apparait le titre).

Pour les figures, vous choisirez probablement Catégorie et hombre (pour insérer le mot
Figure et son numéro), Référence (pour insérer le mot Figure avec son numéro et le texte
complet de la Iégende), Page (pour insérer le numéro de page sur laquelle se trouve la
figure), ou Numéro (pour insérer uniquement le numéro de la figure).

Cliguez sur le bouton Insérer.

Pour obtenir une liste complete des formats de références disponibles et leur utilisation possible,
référez-vous a l'aide du logiciel.

Formats disponibles

Pour tous les types de référence, vous pouvez sélectionnez l'un des formats suivants :

Page : le numéro de page de la cible.
Chapitre : le numéro du chapitre ou la référence cible se situe.
Référence : le texte complet défini comme référence.

Supralinfra : insére les mots Supra (au-dessus) ou Infra (au-dessous) en fonction de la
position du champ relative a la cible référencée.

D'aprés le style de page : similaire & Page, cela insére le numéro de page de la
référence, mais en utilisant le formatage spécifié du style de page. C'est trés utile lorsque
I'on insére une référence a une page de garde ou les chiffres romains sont habituellement
utilisés.

Si vous sélectionnez le type titres ou numeéros de paragraphe, les deux options suivantes sont
disponibles :

Numéro (sans contexte) : insére uniquement le numéro du titre ou du paragraphe
numéroté. Par exemple, si vous référencez un élément numéroté 2.4, cela insére 4.

Numéro (contexte complet) : insére le numéro complet incluant les niveaux hiérarchiques
supérieurs. Par exemple, si vous référencez un élément numéroté 2.4, la numérotation
compléte (2.4) est insérée.

Enfin, pour les objets insérés avec des légendes, tels que les tableaux et les figures, vous pouvez
choisir :

Catégorie et huméro : insére la catégorie et le numéro de l'objet référencé (par exemple,
Figure 6). C'est généralement le format le plus utilisé pour les figures ou les tableaux.

Légende de texte : insére la Iégende compléte de I'objet référencé (par exemple, Figure :
c'est une figure d'exemple).

Numérotation : insére le numéro de séquence de l'objet référencé, sans la catégorie (par
exemple, si vous référencez le tableau 2, le champ contiendra uniquement le numéro 2).
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Préparer les éléments cibles pour le renvoi

Occasionnellement, vous insérerez un renvoi a quelque chose qui n'est pas automatiquement
affiché dans l'onglet Renvois de la boite de dialogue Champs. Avant de pouvoir insérer un renvoi
vers un tel élément, vous devez préparer I'élément comme cible afin qu'il puisse étre référencé.
Pour ce faire, vous pouvez utiliser les reperes de texte ou définir une référence.

Aprés avoir défini une cible, vous pouvez y insérer un renvoi comme décrit en page 13. Pour un

exemple d'utilisation de cette technique, référez-vous a la section Résoudre le probléme du
nombre de pages, du chapitre 4, Formater les pages, de ce guide.

Utiliser les repéres de texte

Les repéres de texte sont répertoriés dans le Navigateur et y sont directement accessibles en un
clic de souris. Dans les documents HTML, les reperes de texte sont convertis en ancres
accessibles a l'aide des hyperliens.

1) Sélectionnez le texte que vous souhaitez définir comme un repére. (Vous pouvez
également insérer un repére a un autre emplacement, sans nécessairement sélectionner
du texte. Il vous suffit de cliguer a l'endroit souhaité). Cliqguez sur le menu Insertion >
Repére de texte.

2) Dans la boite de dialogue Insérer un repére de texte, la zone la plus large répertorie les
repéres précédemment définis (voir Figure 10). Saisissez un nom de repére dans la zone
supérieure de la boite de dialogue. Cliquez sur le bouton OK pour valider.

Insérer un repere de texte

insertpagenum | OK .
usedocproperties
Annuler
Supprimer

Figure 10. Insérer un repére de texte.

Définir des références
1) Cliguez sur le menu Insertion > Champs ou appuyez sur les touches Ctrl+F2 de votre
clavier pour ouvrir la boite de dialogue Champs.
2) Dans l'onglet Renvois (voir Figure 11), cliquez sur Définir une référence dans la liste

Type de champ. La liste Sélection affiche toutes les références qui ont été définies. Vous
pouvez laisser cet onglet ouvert pendant que vous définissez les autres références.
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3)

4)

5)

Document|Renvois | Fonctions| Info document Variables Base de données

Type de champ Sélection

= et A
Insérer une référence
Titres

Paragraphes numérotés
Figure

Reperes de texte

nsérer une référence a Nom

Mots

_,,

ll'.l
™
=

Insérer | | Fermer Aide

Figure 11. Définir un texte a utiliser comme cible pour un renvoi.

Cliquez dans le document pour mettre le texte du premier élément a définir comme une
cible de renvois en surbrillance. Cliguez dans la boite de dialogue Champs. Le texte de
I'élément va apparaitre dans le champ Valeur dans la partie inférieure droite. Dans le
champ Nom, saisissez un texte par lequel vous pourrez identifier cet élément.

Cliquez sur le bouton Insérer. Le texte que vous avez saisi dans le champ Nom apparait
maintenant dans la liste Sélection.

Répétez les étapes 3 et 4 autant de fois que nécessaire.

Utiliser des champs dans les en-tétes et pieds de page

Vous pouvez insérer des champs dans I'en-téte ou le pied de page du document en utilisant la
technique décrite plus tét dans ce chapitre :

Pour insérer un numéro de page, le titre du document, l'auteur, la date et I'heure actuelles,
ou le nombre total de pages, utilisez les propriétés du document (voir page 6) ou cliquez
sur le menu Insertion > Champs > [Choisissez un élément].

Vous pouvez insérer un renvoi a un repere de texte, un titre ou d'autres éléments en
cliguant sur le menu Insertion > Champs > Autres > Renvois.

Si vous avez utilisé Titre 1 pour les titres des chapitres, vous pouvez utiliser un champ de
document pour insérer le titre actuel du chapitre (voir Figure 12)., de fagon a ce que le
contenu des en-tétes ou des pieds de pages change d'un chapitre a l'autre (Writer appelle
les titres de chapitre Noms de chapitre). Si vous avez utilisé la numérotation des chapitres
sur le Titre 1, vous pouvez choisir d'inclure cette numérotation dans le champ (Numéro de
chapitre et Nom de chapitre). Cliquez sur le menu Insertion > Champs > Autres >
Document pour insérer ce type de champ.
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Document | Renvois|Fonctions Info document|Variables Base de données

Type de champ Sélectionner Formagt
Date Numeéro de chapitre
Expéditeur Numeéro de chapitre sans sépara
Heure Numeéro et nom de chapitre
Modéles
Nom de fichier
Page
Statistiques
Utilisateur
k
Niveau
1 =
| Inserer |  Fermer Aide

Figure 12. Insérer le nom et le numéro du chapitre actif dans votre document.

* Vous pouvez insérer des renvois a d'autres niveaux de titre en spécifiant une valeur dans
le champ Niveau dans la partie inférieure droite de l'onglet Document de la boite de
dialogue Champs (voir Figure 12), c'est-a-dire Niveaul = Titrel, Niveau2 = Titre2, et
ainsi de suite.

Un champ de renvoi dans I'en-téte d'une page prend le premier titre de ce niveau

Remarque : I :

sur la page, et un champ dans le pied de page prend le dernier titre de ce niveau.

* Pour inclure le numéro de chapitre avec le numéro de page, positionnez le curseur juste
avant le champ Page que vous avez inséré. Cliquez sur le menu Insertion > Champs >
Autres > Document. Sélectionnez Chapitre dans la colonne Type de champ et
sélectionnez Numéro de chapitre sans séparateur dans la colonne Format. Cliquez sur
le bouton Insérer.

Allez a I'en-téte ou au pied de page ou le champ a été inséré, saisissez le caractere que
vous souhaitez ajouter entre le numéro de chapitre et le numéro de page (par exemple,
une virgule ou une barre oblique).

La table des matiéres ne prendra pas automatiguement ces numéros de chapitre. Vous
devrez donc faire des modifications dans la boite de dialogue Index et tables. Pour plus
d'informations, référez-vous au chapitre 12, Créer des tables de matiéres, des index et des
bibliographies, de ce guide.

* Vous pouvez ajouter un champ Nombre de page au pied de page (par exemple, Page 9
de 12). Saisissez le mot Page et un espace en face du champ Page. Saisissez un espace,

le mot de, et un espace apres le champ Page. Puis cliquez sur le menu Insertion >
Champs > Nombre de pages.
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Utiliser des champs a la place de la numérotation des
chapitres

Le chapitre 6, Introduction aux styles, de ce guide décrit comment utiliser les styles de
paragraphes pour définir une hiérarchie des titres a inclure dans une table des matiéres.

Cette méthode comporte une limitation majeure : seul un style de paragraphe peut étre sélectionné
pour chaque niveau de titre, et une seule séquence de numérotation peut étre spécifiée dans le
menu Outils > Numérotation des chapitres. Cependant, de nombreux livres contiennent des
annexes (habituellement désignées A, B, C) en plus des chapitres (désignés habituellement par 1,
2, 3).

Pour résoudre ce probléme, vous pouvez utiliser un style de paragraphe (Titrel) pour les noms
des chapitres et des annexes, et définir deux champs de séquence différents pour les chapitres et
les annexes. Le champ de séquence des chapitres utilisera des nombres et le champ de séquence
des annexes utilisera des lettres. Vous pouvez donc utiliser le méme champ dans l'en-téte et le
pied de page des chapitres et des annexes.

1) Définissez la premiere séquence de numérotation variable (voir la section Définir des
séquences de numérotation personnalisées en page 10). Pour insérer le champ dans le
Titre 1, saisissez Chapitre<espace>. Cliquez ensuite sur le menu Insertion > Champs
> Autres > Variables. Sélectionnez Séquence (liste Type de champ), puis Chapitre (liste
Sélection) et enfin Arabe (1 2 3) (liste Format). Cliquez sur le bouton Insérer. Vous
devrez effectuer manuellement cette procédure pour chaque Titre 1 qui doit étre un titre de
chapitre.

2) Définissez la seconde séquence de numérotation variable pour les annexes. Saisissez
Annexe<espace>. Cliquez ensuite sur le menu Insertion > Champs > Autres >
Variables (voir Figure 13). Sélectionnez Séquence (liste Type de champ), puis Chapitre
(liste Sélection) et enfin A B C (liste Format). Cliquez sur le bouton Insérer. Répétez cette
procédure pour chaque Titre 1 qui doit étre un titre d'annexe.

3) Lorsque vous créerez la table des matiéres, les chapitres et les annexes seront désignés
correctement.

Document Renvois Fonctions Info document|Variables Base de données

Type de champ Sélection Format

Définir une variable

Afficher la variable Figure abc

Champ DDE lustration AL AA L AAA

Insérer une formule Tableau a..aa..aaa

Champ de saisie Texte Romain (1 1111)
Romain (i ii iii)

Définir une variable de page Arabe (12 3)

Afficher la variable de page A, B, .., Aa, Ab, ... (bg)

Champ d'utilisateur a,b,..,aa, ab, .. (bg)

A, B, .., Aa, B6, ... (bg)
a, 6, ., aa, 66, .. (bg) =

Mumeérotation par chapitre

Niveau Aucun =
Séparateur
MNom Valeur
Annexe]
o Inseérer | | Fermer Aide

Figure 13. Définir une séquence de numérotation variable pour les annexes.
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Astuces pour travailler avec les champs

Raccourcis claviers pour les champs

Voici quelques raccourcis clavier pratiques a utiliser lorsque vous travaillez avec les champs :

Ctrl+F2 Ouvrir la boite de dialogue Champs.
Ctri+F8 (Dés)Activer la trame de fond des champs.
Ctrl+F9 Afficher ou masquer les noms de champ.
F9 Actualiser les champs.

Rendre fixe le contenu d'un champ

Vous pouvez cocher I'option Contenu fixe pour de hombreux éléments des onglets Document et
Info document de la boite de dialogue Champs. Cette option fait en sorte que le contenu du
champ ne soit pas actualisé. Par exemple, si vous insérez un champ pour indiquer la date de
création du document, cette derniere ne devra pas étre modifiée. Par contre, si vous insérez a un
autre endroit un champ de date pour indiquer la date actuelle, cette derniere devra étre actualisée.
Dans ce dernier cas, décochez 'option Contenu fixe lors de l'insertion du champ.

Convertir des champs en texte

Writer ne propose pas un moyen facile de convertir un contenu de champ en texte. Cependant, il
est possible de copier le contenu du champ et de le coller comme texte non formaté :

1) Sélectionnez le champ et cliquez sur le menu Edition > Couper ou appuyez sur les
touches Cirl+X de votre clavier.

2) Cliquez sur le menu Edition > Collage spécial. Cliquez sur l'option Texte non formaté
dans la liste Sélection. Cliquez ensuite sur le bouton OK. Pour éviter de passer par les
menus, appuyez sur les touches Ctrl+Alt+Maj+V de votre clavier pour coller du texte non
formaté.

Cette solution n'est pas pratique si vous avez des centaines de champs a modifier. Dans ce cas, il
est conseillé de créer une macro pour automatiser le processus.

Aprés avoir changé un champ en texte, il ne vous sera pas possible d'utiliser la procédure inverse
pour convertir du texte en champ.

Développer du contenu conditionnel

Un contenu conditionnel consiste en du texte ou des objets (images, graphiques, dessins, etc.) qui
sont inclus ou exclus en fonction d'une condition que vous spécifiez.

L'exemple le plus simple consiste en une lettre de rappel pour une facture non payée. Les premier
et second rappels peuvent avoir pour objet Rappel, tandis que la troisieme relance aura pour objet
Derniére relance ou Mise en demeure ainsi gu'un paragraphe final différent des autres courriers.

Un exemple plus complexe consiste en un guide logiciel pour un produit qui concerne deux
versions, la version professionnelle et la version standard. Les deux versions du produit ont
beaucoup en commun, mais la version professionnelle inclut certaines fonctions qui ne sont pas
présentes dans la version standard. Si vous utilisez un contenu conditionnel, vous pouvez
maintenir un seul fichier contenant les informations pour les deux versions et imprimer (ou créer
une aide en ligne) une version personnalisée pour chaque version. Vous n'‘avez pas a maintenir
deux ensembles d'informations qui sont les mémes pour les deux versions, vous n'oublierez pas
ainsi de mettre a jour les deux versions lorsqu'il faut apporter une modification.
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Choisir le type de contenu conditionnel a utiliser

Cette section décrit plusieurs fonctions de Writer qui aident a la création et au maintien de contenu
conditionnel. Vous pouvez en utiliser seulement une ou les combiner dans le méme document.

Texte conditionnel

Avec du texte conditionnel, vous pouvez avoir deux textes alternatifs (un mot ou tout ou partie
d'une phrase). Un des textes sera affiché et imprimé si la condition que vous avez spécifiée est
remplie, et l'autre sera affiché et imprimé si la condition exprimée n'est pas remplie. Vous ne
pouvez pas inclure d'objets (images, graphiques, dessins, etc.) ou éditer le texte sauf dans la boite
de dialogue Champ (pas dans le corps du document). Vous ne pouvez pas non plus formater une
partie du texte (par exemple, mettre en gras un mot mais pas les autres), mais vous pouvez
formater le champ afin que cela affecte tout le contenu du champ (par exemple, mettre en gras
tous les mots). Vous ne pouvez pas inclure un renvoi ou un autre champ dans le texte.

Texte masqué

Avec le texte masqué (un mot ou tout ou partie d'une phrase), vous avez seulement deux
possibilités : afficher ou masquer. Si la condition spécifiée est remplie, le texte est caché ; si la
condition ne l'est pas, le texte est affiché. Les désavantages sont les mémes que pour un texte
conditionnel : vous ne pouvez pas inclure d'objets (images, graphiques, dessins, etc.) ou éditer le
texte dans le corps du document, formater une partie du texte ou inclure un champ.

Paragraphe masqué

Un paragraphe masqué est comme tout autre paragraphe, mais vous pouvez spécifier une
condition selon laquelle le paragraphe n'est pas affiché ou imprimé. Un paragraphe vide peut aussi
étre masqué (par exemple, si un champ de base de données n'a pas de contenu pour
I'enregistrement actif). C'est trés utile lors de la fusion des adresses dans une lettre : si vous avez
deux lignes pour la rue de l'adresse et que l'enregistrement de la base de données n'en comporte
gu'une, vous pouvez éviter l'apparition d'une ligne vide dans le document. Vous pouvez inclure des
images, éditer le corps du texte dans le document, formater n'importe quelle partie du texte et
inclure des champs.

Section masquée

Une section masquée est comme un paragraphe masqué, mais elle peut inclure plus d'un
paragraphe (par exemple, un en-téte et un ou plusieurs paragraphes). Cependant, une section ne
peut contenir moins d'un paragraphe, vous ne pouvez donc pas utiliser cette méthode pour un mot
ou des parties de phrases. Le contenu d'une section masquée se comporte comme le contenu de
n'importe quelle autre partie du document, mais vous pouvez spécifier une condition selon laquelle
la section ne sera pas affichée ou imprimée. De plus, vous pouvez protéger une section avec un
mot de passe.

Prévoir votre contenu conditionnel

Les conditions sont ce que les programmeurs appellent des expressions logiques. Vous devez
formuler une expression logique pour chaque condition parce qu'une condition est toujours, soit
vraie (remplie), soit fausse (non remplie). Vous pouvez utiliser la méme condition a plusieurs
endroits du document, et ce pour différents types de contenu conditionnel.
Pour que le contenu conditionnel fonctionne, vous devez :

1) choisir ou définir une variable ;

2) définir une expression logique (la condition) impliquant la variable sélectionnée.
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Choisir ou définir une variable
Vous pouvez utiliser les variables citées ci-aprés pour vos propres conditions :
* les variables définies par l'utilisateur ;

* les variables prédéfinies par LibreOffice qui utilisent les valeurs statistiques des propriétés
du document ;

* les données d'identité ;
* e contenu des champs de base de données (par exemple, votre carnet d'adresses).

Vous ne pouvez pas utiliser des variables internes (par exemple, un numéro de page ou le nom
d'un chapitre) pour formuler des conditions.

Les exemples de ce chapitre utilisent des variables définies par I'utilisateur.

Définir une expression logique (condition) impliquant la variable sélectionnée
La condition compare une valeur fixe spécifiee avec le contenu d'une variable ou d'un champ de
base de données.

Pour formuler une condition, utilisez les mémes éléments que vous auriez utilisés pour créer une
formule : des opérateurs, des fonctions statistiques ou mathématiques, des formats de nombre,
des variables et des constantes. Les opérateurs possibles sont donnés dans l'aide du logiciel,
faites une recherche sur Opérateurs : dans les formules. Vous pouvez définir des expressions
assez complexes, mais dans la plupart des cas, une condition simple suffira.

Créer la variable

Pour créer votre variable, cliquez sur le menu Insertion > Champs > Autres ou appuyez sur les
touches Ctrl+F2 de votre clavier. Utilisez les options disponibles dans les onglets Info document,
Variables et Base de données.

Champs de I'onglet Info document

La section Utiliser les propriétés du document pour gérer les informations modifiables en page 6
expligue comment définir une propriété de document personnalisée. Vous pouvez utiliser une
propriété de document comme variable de base pour votre condition, ou vous pouvez créer un
autre champ de propriété de document spécifique pour votre condition.

Champ de variable définie par I'utilisateur
Pour définir un champ de variable personnalisée :
1) Placez le curseur a I'endroit ou vous souhaitez insérer le champ.
2) Dans la boite de dialogue Champs, sélectionnez I'onglet Variables (voir Figure 14).
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Document Renvois Fonctions Info document Variables Base de données

Type de champ Sélection Format

F

NIT L

cvhef'la varlabie .Stanéll.'ard

AFFi

Champ DDE -1234

Insérer une formule -1234,12

Champ de saisie -1.234

Séquence -1.234,12
Définir une variable de page Autres formats...

Afficher la variable de page
Champ d'utilisateur

Nom Valeur

ProStand Standard

Inseérer | | Fermer Aide
Figure 14. Définir une variable a utiliser avec un contenu conditionnel.

3) Sélectionnez Définir une variable dans la liste Type de champ et sélectionnez Texte
dans la liste Format. Dans le champ Nom, saisissez par exemple ProStand (pour vous
rappeler que la variable est relative aux deux versions du produit). Dans le champ Valeur,
saisissez par exemple Standard (pour vous rappeler qu'il s'agit de la version standard du
produit et que le texte doit de ce fait étre masqué).

4) Cochez l'option Invisible de facon a ce que le champ n'apparaisse pas dans le document.
Cliquez ensuite sur le bouton Insérer puis sur le bouton Fermer.

5) Une petite marque grise devrait étre visible a l'endroit ou vous avez inséré le champ.
Survolez cette marque avec la souris et la formule de champ ProStand = Standard
s'affichera. Nous reviendrons & ce champ plus tard.

Dans la mesure ou la marque grise est toute petite, vous aurez peut-étre du mal a
la retrouver, surtout si vous avez d'autres champs dans le document. Vous
choisirez sans doute de laisser le champ de variable visible pendant la durée de
votre travail et le modifier comme invisible juste avant de créer la copie finale.

Astuce A tout moment, vous pouvez placer le point d'insertion juste avant le champ et
cliquer sur le menu Edition > Champs (voir Figure 18) ou faire un clic avec le
bouton droit sur le champ et cliquer ensuite sur Champs dans le menu contextuel.
Dans la boite de dialogue Editer les champs, cochez ou décochez l'option
Invisible.
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Appliquer la condition au contenu

Maintenant que vous avez défini la variable, vous pouvez l'utiliser dans une instruction de
condition. Cette section décrit certaines possibilités.

Texte conditionnel

Tout d'abord, définissez du texte conditionnel qui permettra d'insérer dans le manuel les mots
Super Produit Standard dans la version standard et Super Produit Pro dans la version
professionnelle. Vous pouvez utiliser ces champs a n'importe quel moment pour mentionner le
nom du produit.

1) Placez le curseur ou vous souhaitez que l'une de ces phrases apparaisse (vous pourrez la
déplacer ou la supprimer ultérieurement, si vous le souhaitez).

2) Ouvrez la boite de dialogue Champs en cliquant sur le menu Insertion > Champs >
Autres. Cliquez sur I'onglet Fonctions et sélectionnez Texte conditionnel dans la liste
Type de champ.

3) Comme montré en Figure 15, saisissez ProStand EQ "Standard" dans le champ
Condition, Super Produit Standard dans le champ Alors et Super Produit Pro dans le
champ Sinon.

Document|Renvois|Fonctions | Info document Variables Base de données
Type de champ Formak Condition

ProStand EQ "Standard"
Liste de saisie

Champ de saisie Alors
Exécuter la macro

: Super Produit Standard
Substituant

Combiner les caracteres Sinon
Texte masqué .
Paragraphe masqué super Produit Pro]

Figure 15. Insérer un texte conditionnel.

Ces champs sont sensibles a la casse et les guillemets sont indispensables autour

Remarque . e s texte comme Standard.

4) Cliquez sur le bouton Insérer pour insérer le champ, puis cliquez sur le bouton Fermer.
Super Produit Standard doit normalement apparaitre dans le texte.

Si vous souhaitez insérer ce champ a plusieurs endroits du document (ce qui est
souvent le cas pour le nom d'un produit), il est conseillé de créer une entrée
d'AutoTexte (voir Utiliser les AutoTextes pour insérer des champs courants en
page 10).

Astuce

Texte masqué

Vous utiliserez du texte masqué pour les mots ou les phrases courtes qui décrivent des fonctions
de Super Produit Pro que I'on ne retrouve pas dans la version Standard. Vous pouvez réutiliser
le méme champ a divers endroits du document (par exemple, en le copiant et le collant).

Pour créer un champ de texte masqué :

1) Cliquez sur le menu Insertion > Champs > Autres pour ouvrir la boite de dialogue
Champs. Cliquez ensuite sur I'onglet Fonctions.
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2)
3)

4)

Dans la liste Type de champ, sélectionnez Texte masqué (voir Figure 16).

Comme montré en Figure 16, saisissez ProStand EQ "Standard" dans le champ
Condition, puis saisissez le texte requis dans le champ Texte masqué. Pour rappel, il
s'agit du texte masqué si la condition est vraie.

Cliquez sur le bouton Insérer pour insérer le champ, puis cliquez sur le bouton Fermer.

Document Renvois|Fonctions | Info document|Variables Base de données

Type de champ Formak Condition

Texte conditionnel ProStand EQ "standard”
Liste de saisie )

Champ de saisie Texte masque

Exécuter la macro

: , et six autres choix
Substituant

Combiner les caractéres

“F"'éra'gr'éllphe |:nasque'

| Inserer |  Fermer Aide

Figure 16. Créer une condition pour du texte masqué.

Paragraphe masqué
Un paragraphe est masqué si la condition est vraie. Pour masquer un paragraphe :

1)
2)

3)
4)
5)

Cliguez dans le paragraphe a masquer.

Cliguez sur le menu Insertion > Champs > Autres pour ouvrir la boite de dialogue
Champs. Cliquez ensuite sur lI'onglet Fonctions (voir Figure 16).

Dans la liste Type de champ, sélectionnez Paragraphe masqué.
Dans cet exemple, saisissez ProStand EQ "Standard" dans le champ Condition.

Cliquez sur le bouton Insérer pour créer et insérer le champ dans le document. Si une
marque de paragraphe supplémentaire apparait, supprimez-la.

Pour afficher les paragraphes masqués dans le but de les éditer, effectuer lI'une des actions
suivantes :

Cliguez sur le menu Affichage > Paragraphes masqués afin de vérifier si I'option
Paragraphes masqués est bien cochée. Si tel n'est pas le cas, cochez-la.

Cliquez sur le menu Outils > Options pour ouvrir la boite de dialogue Options. Cliquez
dans la sous-section LibreOffice Writer > Aides au formatage. Cochez I'option Champs :
paragraphes masqués.

Double-cliquez en face de la variable que vous avez utilisée pour définir la condition afin de
masquer le texte, et saisissez une valeur de variables différente (cela permet d'afficher tous
les paragraphes masqueés).
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* Double-cliqguez en face du champ de texte masqué ou du champ de paragraphe masqué,
et modifiez l'instruction de condition (cela permet de modifier uniguement le paragraphe
masqué sélectionné).

Section masquée

Une section conditionnelle est masquée si la condition est vraie. Pour créer une section
conditionnelle :

1) Sélectionnez le texte que vous souhaitez inclure dans une section conditionnelle. (Vous
pourrez éditer le texte plus tard, exactement comme vous pouvez éditer tout autre texte.)

2) Cliquez sur le menu Insertion > Section pour ouvrir la boite de dialogue Insérer une
section (voir Figure 17). Cliquez sur l'onglet Section. Cochez l'option Masquer puis
saisissez la condition dans le champ Sous condition. Si vous le souhaitez, vous pouvez
donner un nom a la section (ce qui est vivement recommandé, car vous retrouverez plus
facilement une section si votre document en contient plusieurs).

3) Cliquez sur le bouton Insérer pour insérer la section dans le document.

Pour afficher une section masquée afin de I'éditer :
1) Cliguez sur le menu Format > Sections.

2) Dans la boite de dialogue Editer les sections (elle ressemble & la boite de dialogue
Insérer une section), sélectionnez la section a éditer dans la liste.

3) Décochez l'option Masquer, puis cliquez sur le bouton OK. Vous pouvez désormais éditer
le contenu de la section. Une fois les modifications effectuées, vous pouvez cliquer sur le
menu Format > Sections et cochez l'option Masquer afin de masquer a nouveau la
section.

Pour afficher toutes les sections masquées afin de les éditer, modifiez la valeur de la variable a
guelque chose que la condition ne reconnaitra pas. Dans notre exemple, vous pouvez modifier la
valeur a 1.

& Insérer une section

Section | Colonnes Retraits Arriére-plan MNotes de bas de page / de fin
Nouvelle section Lier

Section1 ] Lier

DD

m

Nom de Fichier
Section

Protection contre les meodifications
| Protéger
Avec mok de passe
Masquer
& Masquer
Sous condition ProStand EQ "Standard”
Propriétés
—| Modifiables dans les documents en lecture seule

nsérer Annuler Aide Réinitialiser

Figure 17. Créer une section a masquer lorsqu'une condition est remplie.
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Pour transformer la section masquée en une partie normale du document (c'est-a-dire pour
supprimer les marqueurs de la section, mais pas son contenu) :

1)
2)

3)

Affichez la section masquée comme décrit ci-avant.

Dans la boite de dialogue Editer les sections, sélectionnez la section a transformer dans
la liste.

Cliquez sur le bouton Supprimer. Le contenu de la section apparait maintenant comme
une partie normale du document.

Modifier la valeur d'une variable

1)
2)
3)

4)

Recherchez le champ de variable créé (voir la section Créer la variable en page 21).
Faites un clic droit sur le champ afin d'ouvrir le menu contextuel, et cliquez sur Champs.

Dans la boite de dialogue Editer les champs : variables (voir Figure 18), modifiez la
valeur de la variable en Pro.

Si vous avez défini des champs a mettre a jour automatiquement, tout le texte conditionnel
et masqué qui utilise cette variable comme condition sera modifié.

Astuce

Les textes conditionnels et masqués ne peuvent étre édités que dans la boite de
dialogue Editer les champs.

@ Editer les champs: Variables

Typedechamp Sélection Format —
Définir une variable Texte e
Annuler
Aide

Nom

& Invisible

Valeur

ProStand Pro

Figure 18. Modifier la valeur de la variable.

Pour désactiver l'actualisation automatique des champs, cliquez sur le menu
Outils > Options. Dans la boite de dialogue Options, cliquez sur la sous-section

Astuce LibreOffice Writer > Général. Dans la partie Actualiser — Automatiquement,

décochez l'option Champs.
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Utiliser des champs substituants

Un champ substituant vous invite a introduire quelque chose (du texte, un tableau, un cadre, une
image, un objet, etc.).
Pour insérer un champ substituant dans un document :

1) Dans l'onglet Fonctions de la boite de dialogue Champs, sélectionnez Substituant dans
la liste Type de champ. Dans la liste Format, choisissez a quoi est destiné le substituant.

2) Dans le champ Substituant, saisissez le texte que vous souhaitez voir apparaitre dans ce
champ.

3) Dans le champ Annotation, saisissez le texte que vous souhaitez voir apparaitre en
infobulle lorsque vous survolerez le champ avec la souris.

La Figure 19 montre un exemple d'insertion d'un champ substituant pour une image.

Document Renvois|Fonctions | Info document| Variables Base de données

<Loco>1|
Type de champ Format Substituant
Insérer votre logo ici Hat T Texte Logo
Liste de saisie Table ]
Champ de saisie Cadre Annotation

Exécuter lamacro . Insérer votre logo ici
Objet
Combiner les caractéres

Texte masqué
Figure 19. Insérer un champ substituant.

Etant donné que le champ <Logo> est un substituant d'image, lorsque vous cliquerez dessus, la
boite de dialogue Insérer une image s'ouvrira. Lorsque vous sélectionnerez I'image et cliquerez
sur le bouton Ouvrir, l'image choisie remplacera le champ substituant dans le document.

De la méme maniére, cliquez sur un substituant de tableau ouvre la boite de dialogue Insérer un
tableau, cliquez sur un substituant de cadre ouvre la boite de dialogue Cadre, et cliquer sur un
substituant d'objet ouvre la boite de dialogue Insérer un objet OLE.

Le substituant de texte est toutefois différent. Vous devez simplement cliquer dessus afin de le
mettre en surbrillance et saisir n'importe quel texte.

Utiliser des champs de saisie et des listes de saisie

Champ de saisie

Un champ de saisie est une variable sur laquelle vous pouvez cliguer dans un document afin
d'ouvrir une boite de dialogue qui vous permet d'éditer le texte affiché dans ledit champ. Pour
insérer un champ de saisie :

1) Cliguez sur le menu Insertion > Champs > Autres pour ouvrir la boite de dialogue
Champs. Cliquez sur l'onglet Fonctions.

2) Dans la liste Type de champ, sélectionnez Champ de saisie (voir Figure 20).

3) (Optionnel.) Saisissez du texte dans le champ Annotation. Ce texte apparaitra comme
une infobulle lorsque vous survolerez le champ de saisie avec votre souris.

4) Dans la petite boite de dialogue qui s'ouvre, saisissez le texte de la variable (il s’agit d'une

bréve explication destinée a l'utilisateur concernant l'utilisation du champ). Si vous le

Utiliser des champs de saisie et des listes de saisie 27



souhaitez, ce texte peut étre le méme que celui saisi dans le champ Annotation a I'étape
précédente.

5) Cliquez sur le bouton OK.

Pour éditer un champ de saisie, cliquez dessus dans le document. Dans la petite boite de dialogue
qui s'ouvre, éditer le texte du champ.

Document| Renvois Fonctions | Info document| Variables | Base de données

Type de champ Format Nom

Texte conditionnel
Liste de saisie

Champ de saisie Annotation
Execu_ter la macro A quoi sert ce champ ?
Substituank
e © crompdesose |
Texte il Champ de saisie
Paragrag gditer
06
A quoi sert cechamp ?
- Annuler
-
Aide
iCro...

TMSETET | LErmer | ﬂldﬁ'

Figure 20. Insérer un champ de saisie.

Pour éditer 'annotation du champ (voir étape 3 ci-avant), faites un clic droit sur le champ et cliquez
sur Champs dans le menu contextuel afin d'ouvrir la boite de dialogue Editer les champs :
fonctions.

© Editer les champs: Fonctions

Type de champ Format Nom . o !
Quelques explications... ;J_
Annotation Annuler
A quoisert ce champ? Aide

Figure 21. Editer un champ de saisie.
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Liste de saisie

Une liste de saisie est un champ de texte qui affiche un élément d'une liste. Pour insérer une liste
de saisie dans un document :

1) Cliquez sur le menu Insertion > Champs > Autres pour ouvrir la boite de dialogue

Champs. Cliquez sur l'onglet Fonctions. Dans la liste Type de champ, choisissez Liste
de saisie.

Document| Renvois | Fonctions |Info document Variables Base de données

Type de champ Format

Elément
Texte conditionnel 3éme élément
Champ de saisie Ajouter
Exécuter la macro o .
substituant Elements de la liskte
Combiner les caractéres 1er élément
Texte masqué 2éme élément
Paragraphe masqué

Supprimer

éplacer vers le hat

Yéplacer vers le ba
Nom

Mom de la liste de saisie]

Insérer Fermer Aide

Figure 22. Définir une liste de saisie.

2) Dans le champ Elément, saisissez le nom d'un élément de la liste, puis cliquez sur le
bouton Ajouter pour l'ajouter a la liste. Recommencez autant de fois que nécessaire. Pour
modifier I'ordre des éléments, sélectionnez un élément dans la liste EIéments de la liste,
puis utilisez les boutons Déplacer vers le haut et Déplacer vers le bas.

3) Dans le champ Nom, saisissez le nom de la liste.

4) Cliquez sur le bouton Insérer.

Pour afficher la boite de dialogue Choisir un élément (voir Figure 23), cliquez sur le champ de la
liste de saisie dans le document.
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Choisir un elément : Nom de la liste de saisie

Editer :
- OK J
1er élément
2?me e}gment Annuler
3éme éléement
Aide
Editer

Figure 23. Choisir un élément d'une liste de saisie.

Pour ajouter, éditer, supprimer des €léments de la liste, ou modifier leur ordre d'apparition dans la
liste, cliquez sur le bouton Editer dans la boite de dialogue Choisir un élément. La boite de
dialogue Editer les champs : fonctions s'affichera.

@ Editer les champs: Fonctions

Type de champ Format Elément
i Qb s
: Annuler
Ajouter
Eléments de la liste Aide
ler élément

3eme élement

Supprimer
éplacer vers le hat

Yéplacer vers le ba

Nom

Nom de la liste de saisie

Figure 24. Editer les éléments d'une liste de saisie.

Pour éditer rapidement tous les champs et les listes de saisie dans un document, appuyez sur les
touches Citrl+Maj+F9 de votre clavier. Le premier champ de saisie ou de liste du document
s'ouvre. Cliquez sur le bouton OK ou sur le bouton Suivant pour déplacer le curseur au champ ou
a la liste de saisie suivant(e). Aprés le dernier champ de saisie ou de liste, cliquez sur le bouton
Suivant ou le bouton OK pour retourner au contenu du document.

Méthode Pour une utilisation plus confortable de ce type de document, enregistrez-le au
. format ott. (modéle de texte). Ainsi, l'utilisateur travaillera sur une copie et sera
alternative  j,,;its 3 saisir les informations a I'ouverture automatisée des dialogues de saisie.
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