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Note pour les utilisateurs Mac

Certains raccourcis claviers sont différents sous Mac de ceux utilisés sous Windows et Linux. Le
tableau ci-dessous donne quelques correspondances pour les instructions de ce guide. Pour une
liste plus détaillée, référez-vous à l'aide du logiciel.

Windows ou Linux Équivalent Mac Effet

Outils > Options LibreOffice > Préférences Accès aux options de paramétrage

Clic droit +clic⌘ Ouvre un menu contextuel

Ctrl (Contrôle)  (⌘ Commande) Utilisé avec d'autres touches

F5 Maj+ +F5⌘ Ouvre le Navigateur

F11 +T⌘ Ouvre la fenêtre Styles et formatage
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Introduction

Ce chapitre aborde les bases du travail avec du texte dans Writer, le module de traitement de texte
de LibreOffice. Il présume que vous êtes familiarisé avec l'utilisation de la souris et du clavier, et
que vous avez pris connaissance des menus et barres d'outils  de Writer ainsi que des autres
points abordés dans le chapitre 1, Introduction à Writer.

Nous  vous  recommandons  également  de  suivre  les  suggestions  faites  dans  le  chapitre  2,
Paramétrer Writer.

Lorsque vous aurez lu ce chapitre, vous serez capable de :

• sélectionner, couper, copier, coller et déplacer du texte ;

• rechercher et remplacer du texte ;

• insérer des caractères spéciaux ;

• formater les paragraphes et les caractères ;

• créer des listes à puces ou numérotées ;

• vérifier l'orthographe, les synonymes et choisir les options de coupure de mots ;

• utiliser  l'AutoCorrection,  la  complétion  des  mots,  les  AutoTextes  et  la  fonction  de
numérotation des lignes ;

• suivre les modifications, annuler et restaurer des modifications et insérer des notes ;

• lier des parties d'un document.

Sélectionner du texte

Avant  que vous ne puissiez faire quoi  que ce soit  avec du texte,  vous devez le  sélectionner.
Sélectionner  du  texte  dans  Writer  est  similaire  à  sélectionner  n'importe  quoi  dans  les  autres
applications.

En plus de sélectionner des blocs de textes, vous pouvez sélectionner des éléments qui ne sont
pas consécutifs et des colonnes (bloc vertical) de texte.

Sélectionner des éléments disjoints
Pour sélectionner des éléments disjoints (voir Figure 1) en utilisant le clavier et la souris :

1) Sélectionnez le premier morceau de texte.

2) Maintenez la touche  Ctrl  enfoncée et utilisez la souris pour sélectionner le morceau de
texte suivant.

3) Répétez l'opération autant de fois que nécessaire.

Vous pouvez travailler avec le texte sélectionné (le copier, le supprimer, en changer le style, etc.).

Pour sélectionner des éléments disjoints en utilisant uniquement le clavier :

1) Sélectionnez le premier morceau de texte. Pour sélectionner du texte à l'aide du clavier,
maintenez la touche Maj enfoncée et utilisez les flèches de direction.

2) Appuyez sur les touches  Maj+F8 de votre clavier afin d'activer le mode  Sélection avec
ajout de Writer.

3) Utilisez les touches de direction de votre clavier pour vous déplacer au début du morceau
de  texte  suivant  à  sélectionner.  Maintenez  la  touche  Maj enfoncée  et  sélectionnez  le
morceau de texte suivant.

4) Répétez l'opération autant de fois que nécessaire.
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Pour quitter le mode Sélection avec ajout, appuyez sur les touches Maj+F8 ou la touche Échap
de votre clavier.

Figure 1. Sélectionner des éléments qui ne sont pas proches les uns des autres.

Sélectionner un bloc de texte vertical
En  utilisant  le  mode  Sélection  par  bloc,  vous  pouvez  sélectionner  un  bloc  vertical  ou  une
"colonne"  de  texte  qui  est  séparée  par  des  espaces  ou  des  tabulations  (comme on  peut  le
rencontrer dans le texte collé depuis des courriels, des listings ou d'autres sources). Pour activer le
mode  Sélection par bloc, cliquez sur le menu  Édition > Mode sélection > Zone de bloc, ou
cliquez dans la  Barre d'état (voir  Figure 2).  Vous pouvez également appuyer sur les touches
Ctrl+Maj+F8 de votre clavier.

Figure 2. Activer le mode Sélection par bloc via la barre d'état.

Vous pouvez maintenant mettre en surbrillance la sélection en utilisant la souris ou le clavier (voir
Figure 4).

Figure 3. Sélectionner un bloc de texte vertical.

Couper, copier et coller du texte

Couper  et  coller  du texte dans Writer  est  similaire à couper  et  copier  du texte dans d'autres
programmes. Vous pouvez copier/déplacer du texte à l'intérieur d'un même document,  ou d'un
document vers un autre document, en glissant le texte, en utilisant les sélections du menu, les
icônes  ou  les  raccourcis  clavier.  Vous  pouvez  également  copier  du  texte  provenant  d'autres
sources, telles que des pages Web, et les coller dans un document Writer.

Pour déplacer (couper et coller) le texte sélectionné en utilisant la souris, cliquez-glissez le texte
sélectionné vers son nouvel emplacement. Pour copier le texte sélectionné en utilisant la souris,
maintenez la touche Ctrl de votre clavier enfoncée pendant que vous cliquez-glissez le texte vers
son nouvel emplacement. Le formatage du texte copié est préservé.
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Après avoir sélectionné du texte, vous pouvez également le couper, le copier et coller du texte de
l'une des manières suivantes :

Couper  :  utilisez  le  menu  Édition >  Couper ou  le  raccourci  clavier  Ctrl+X ou  l'icône
Couper de la barre d'outils Standard. 

Copier : utilisez le menu Édition > Copier ou le raccourci clavier Ctrl+C ou l'icône Copier
de la barre d'outils Standard. 

Coller : utilisez le menu Édition > Coller ou le raccourci clavier Ctrl+V ou l'icône Coller de
la barre d'outils Standard.

Le résultat  d'une opération de collage dépend de la source du texte à coller.  Si  vous cliquez
simplement sur l'icône Coller, quel que soit le formatage du texte (tel que gras ou italique), il est
préservé. Le texte collé des sites Web ou d'autres sources peut également être placé dans des
cadres ou dans des tableaux. Si  le résultat ne vous paraît pas satisfaisant, cliquez sur l'icône
Annuler ou appuyez sur Ctrl+Z).

Pour faire en sorte que le collage prenne le formatage du texte qui l'entoure à l'endroit où il est
collé :

• Cliquez sur le menu Édition > Collage spécial ou...

• Cliquez sur le triangle situé à droite de l'icône Coller dans la barre d'outils Standard ou...

• Cliquez sur l'icône Coller sans relâcher le bouton gauche de la souris ou...

• Appuyez sur les touches Ctrl+Maj+V de votre clavier.

Ensuite, cliquez sur Texte non formaté dans la boîte de dialogue ou le menu déroulant.

L'étendue des choix dans le menu Collage spécial varie en fonction de l'origine et du formatage
du texte (ou des autres objets) à coller. Voir Figure 4 pour un exemple de texte du presse-papiers.

Figure 4. Menu Collage spécial.

Rechercher et remplacer du texte et du formatage

Writer a deux moyens de trouver du texte dans un document : la barre d'outils Rechercher pour
une recherche rapide et la boîte de dialogue Rechercher & Remplacer. Dans la boîte de dialogue
Rechercher & Remplacer, vous pouvez :

• trouver et remplacer des mots ainsi que des phrases ;

• utiliser les caractères génériques et les expressions régulières pour affiner la recherche ;

• rechercher et remplacer des formatages spécifiques ;

• rechercher et remplacer des styles de paragraphe.

Utiliser la barre d'outils Rechercher
Si la barre d'outils  Rechercher  n'est pas visible, vous pouvez l'afficher en cliquant sur le menu
Affichage >  Barres d'outils  >  Rechercher ou  en  appuyant  sur  les  touches  Ctrl+F  de  votre
clavier.  Par défaut, la barre d'outils  Rechercher est ancrée au bas de la fenêtre de LibreOffice,
juste au-dessus de la barre d'état (voir  Figure 5). Vous pouvez également la rendre flottante ou
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l'ancrer à un autre endroit.  Pour plus d'information sur les barres d'outils flottantes et ancrées,
référez-vous au chapitre 1, Introduction à Writer, de ce guide.

Figure 5. Position par défaut de la barre d'outils Rechercher.

Pour utiliser la barre d'outils Rechercher, cliquez dans le champ et saisissez le texte à rechercher.
Appuyez ensuite sur la touche  Entrée de votre clavier pour trouver la prochaine occurrence du
texte saisi.  Cliquez sur  les  boutons  Rechercher  le  suivant ou  Rechercher  le  précédent en
fonction de vos besoins.

Utiliser la boîte de dialogue Rechercher & remplacer
Pour  afficher  la  boîte  de  dialogue  Rechercher  &  remplacer,  cliquez  sur  le  menu  Édition  >
Rechercher & remplacer ou appuyez sur les touches Ctrl+H de votre clavier. Pour obtenir plus
d'options, cliquez sur le bouton Plus d'options de la boîte de dialogue (voir Figure 6).

Pour utiliser la boîte de dialogue Rechercher & remplacer :

1) Saisissez le texte que vous souhaitez trouver dans le champ Rechercher.

2) Pour remplacer le texte recherché avec un texte différent, saisissez le nouveau texte dans
le champ Remplacer par.

3) Vous  pouvez  sélectionner  des  options  telles  que  Respecter  la  casse,  Mots  entiers
uniquement ou Rechercher des similarités (voir ci-après pour d'autres choix).

4) Lorsque  vous  avez  défini  votre  recherche,  cliquez  sur  le  bouton  Rechercher.  Pour
remplacer le texte, cliquez sur le bouton Remplacer.

Astuce
Si  vous  cliquez  sur  le  bouton  Tout  rechercher,  Writer  sélectionne  toutes  les
occurrences du texte recherché dans le  document.  De la  même façon,  si  vous
cliquez sur le bouton Tout remplacer, Writer remplace toutes les occurrences.

Attention Utilisez le bouton Tout remplacer avec précaution ; vous pourriez provoquer des
erreurs  embarrassantes.  Une  erreur  avec  le  bouton  Tout  remplacer peut
nécessiter une recherche manuelle, mot par mot, pour la corriger si elle n'est pas
découverte à temps pour l'annuler.
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Figure  6.  Boîte  de  dialogue  Rechercher  &  remplacer  avec  les
options supplémentaires.

Rechercher et remplacer du formatage spécifique
Le  bouton  Format de  la  boîte  de  dialogue  Rechercher  &  remplacer permet  d'affiner  les
recherches. Par exemple, vous pourriez devoir remplacer les mots soulignés en italique.

Dans  la  boîte  de  dialogue  Rechercher  & remplacer (avec le  bouton  Plus  d'options activé,
comme montré sur la Figure 6) :

1) Pour rechercher du texte en particulier avec un formatage spécifique, saisissez ce texte
dans  le  champ  Rechercher.  Pour  rechercher  uniquement  un  formatage  spécifique,
supprimez tout ce que pourrait contenir le champ Rechercher.

2) Cliquez  sur  le  bouton  Format pour  afficher  la  boîte  de  dialogue  Format  de  texte
(Rechercher). Les onglets de cette boîte de dialogue sont similaires à ceux des boîtes de
dialogue Paragraphe et Caractère.

3) Choisissez les caractéristiques du format à rechercher (par exemple, n'importe quel texte
formaté  en  Times  New  Roman,  Taille  14,  Gras)  et  cliquez  sur  le  bouton  OK.  Les
caractéristiques définies apparaissent en dessous du champ Rechercher.

4) Pour remplacer uniquement le texte, saisissez simplement le texte de remplacement dans
la boîte Remplacer par.

Pour remplacer uniquement le formatage, cliquez dans le champ Remplacer par, laissez-
le vide et cliquez sur le bouton  Format afin de définir les nouvelles caractéristiques qui
apparaîtront en dessous du champ Remplacer par.
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Pour remplacer le texte ainsi que le formatage, saisissez le texte de remplacement dans le
champ  Remplacer  par et  cliquez  sur  le  bouton  Format pour  définir  les  nouvelles
caractéristiques qui apparaîtront en dessous du champ Remplacer par.

Pour supprimer un formatage spécifique, cliquez sur le bouton Format, puis sélectionnez
dans les  onglets  les  formats  opposés (par  exemple,  Pas de gras).  Le  bouton  Aucun
format permet de supprimer l'intégralité des caractéristiques définies, que ce soit dans le
champ Rechercher ou dans le champ Remplacer par.

5) Cliquez sur les boutons Rechercher, Tout rechercher, Remplacer ou Tout remplacer en
fonction de vos besoins.

Astuces

Les attributs résultant d'un style de caractère (le  gras pour le style  Accentuation
forte par exemple) ne sont trouvés par la recherche que si vous cochez l'option Y
compris les styles.

Sauf si vous souhaitez rechercher d'autres textes ayant les mêmes caractéristiques,
cliquez  le  bouton  Aucun  format pour  supprimer  les  caractéristiques.  Si  vous
oubliez cette étape,  il  se peut  que vous vous demandiez pourquoi  la recherche
échoue alors  que vous savez pertinemment  que le  mot  est  présent  dans votre
document.

Rechercher et remplacer des styles de paragraphes
Si vous copiez et collez du texte provenant de différentes sources (sans avoir recours à la fonction
Collage spécial > Texte non formaté), vous vous rendrez compte que les styles ont également
été copiés dans votre document. Il est possible de modifier les différents styles des paragraphes
en un style propre à votre document :

1) Dans  la  boîte  de  dialogue  Rechercher  & remplacer (avec  le  bouton  Plus  d'options
activé, comme montré sur la  Figure 6), cochez l'option  Rechercher des styles (si vous
avez défini  des caractéristiques,  voir  la  section  Rechercher  et  remplacer  du formatage
spécifique en  page  10,  cette  option  s'appellera  Y compris  les  styles).  Les  champs
Rechercher et Remplacer par contiennent désormais la liste des styles disponibles.

2) Sélectionnez les styles que vous souhaitez rechercher et remplacer.

3) Cliquez sur les boutons Rechercher, Tout rechercher, Remplacer ou Tout remplacer en
fonction de vos besoins.

Répétez les étapes 2 et 3 pour chaque style que vous souhaitez modifier.

Utiliser des métacaractères et des expressions régulières
Un métacaractère est un caractère spécial qui remplace un ou plusieurs caractères non définis.
Ils  permettent  d'effectuer  une  recherche plus  large,  mais  moins  affinée.  En  outre,  il  vous est
possible de recourir à des combinaisons de caractères, appelées expressions régulières, afin de
faire des recherches plus poussées qu'avec les métacaractères, même si celles-ci restent moins
précises  qu'une  chaîne  de  caractères  littérale.  Les  expressions  régulières  s'avèrent  très
puissantes mais peu intuitives. Elles peuvent vous faire gagner du temps et vous épargner bien
des efforts si vous les combinez lors d'une seule et même recherche.

Le Tableau 1 vous montre quelques-unes des expressions régulières utilisées par LibreOffice.

Astuce L'aide décrit bien plus d'expressions régulières et leur usage.
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Pour  utiliser  les  métacaractères  et  les  expressions  régulières  lors  d'une  recherche  et  d'un
remplacement :

1) Dans  la  boîte  de  dialogue  Rechercher  & remplacer (avec  le  bouton  Plus  d'options
activé, comme montré sur la Figure 6), cochez l'option Expressions régulières.

2) Dans le champ Rechercher, saisissez le texte à rechercher, y compris les métacaractères.
Dans le champ Remplacer par, saisissez le texte de remplacement si besoin. Toutes les
expressions  régulières  ne  fonctionnent  pas  comme  caractère  de  remplacement  (par
exemple, le saut de ligne \n).

3) Cliquez sur les boutons  Rechercher,  Tout rechercher,  Remplacer ou  Tout remplacer
(déconseillé dans ce cas) en fonction de vos besoins.

Remarque

Pour rechercher un caractère défini  par  un métacaractère,  saisissez devant le
caractère une barre oblique inversée (\) afin d'indiquer à Writer que vous l'utilisez
de façon littérale.  Par exemple, pour rechercher le texte  $5.00,  vous saisirez  \
$5\.00).

Tableau 1. Exemples de métacaractères et d'expressions régulières

Pour rechercher...
Utilisez cette 
expression

Exemples et commentaires

N'importe quel caractère 
unique

. b.c trouve bec, bac et bic.

Un des caractères 
spécifiés

[xyz] b[eo]n trouve ben et bon.

Tout caractère unique 
dans la plage

[x-y] [r-t]oute trouve route, soute et toute; les plages 
doivent être en ordre alphabétique ascendant.

Tout caractère unique 
sauf les caractères entre 
crochets

[^x] gr[^a]s trouve gros et grès, mais pas gras.

Le début d'un mot \<début \<log trouve logique et logistique, mais pas 
catalogue.

La fin d'un mot fin\> fact\> trouve artefact, mais pas facture.

Une marque de 
paragraphe

$ Ne fonctionne pas comme caractère de 
remplacement. Utilisez \n à la place.

Un saut de ligne \n Trouve un saut de ligne qui a été inséré avec les 
touches Maj+Entrée. Insère une marque de 
paragraphe lorsqu'utilisé comme caractère de 
remplacement.

Insérer des caractères spéciaux
Un  Caractère spécial est un caractère qui n'est pas présent sur un clavier standard de votre
langue. Par exemple, © ¾ æ ç Ł ñ ö ø ¢ sont des caractères spéciaux. Pour insérer un caractère
spécial :

1) Placez le curseur de la souris à l'endroit où vous souhaitez insérer le caractère spécial
dans votre document.
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2) Cliquez sur le menu  Insertion > Caractères spéciaux pour ouvrir la boîte de dialogue
Caractères spéciaux (voir Figure 7).

3) Sélectionnez dans l'ordre les caractères (de n'importe quelle police ou sous-ensemble) que
vous souhaitez insérer.  Le caractère sélectionné (et son code numérique) est  affiché à
droite de la boîte de dialogue, en dessous des boutons. Vous pouvez également visualiser
tous les caractères choisis en bas à gauche de la boîte de dialogue (voir Figure 7). Cliquez
ensuite sur le bouton OK pour insérer le(s) caractère(s) dans votre document.

Astuces

Différentes polices incluent différents caractères spéciaux. Si vous ne trouvez pas
un caractère spécial particulier, essayez de changer la Police.

La commande Rechercher & Remplacer permet l'accès aux caractères spéciaux
par un clic droit dans les zones Rechercher et Remplacer par.

Figure 7. La boîte de dialogue Caractères spéciaux.

Insérer des espaces et des tirets insécables

Espaces insécables
Afin d'éviter que deux mots ne soient séparés à la fin d'une ligne, appuyez sur les touches
Ctrl+Maj de votre clavier lorsque vous saisissez l'espace entre les deux mots.

Tirets insécables
Vous pouvez utiliser un tiret insécable dans le cas où vous ne souhaitez pas que le trait d'union
apparaisse à la fin d'une ligne (par exemple : dans un nombre tel que 123-4567). Pour insérer
un tiret insécable, appuyez sur les touches Ctrl+Maj+signe moins de votre clavier.

Les espaces et  les tirets  insécables peuvent  également  être insérés via le  menu  Insertion >
Marque de formatage.

Insérer des tirets cadratins et demi-cadratins
Pour saisir des tirets cadratins (tirets longs) et demi-cadratins (tirets), vous pouvez utiliser l'option
Remplacer les tirets (active par défaut) dans le menu Outils > Options d'AutoCorrection (voir
Figure 16 en page  19). Cette option remplace deux tirets sous certaines conditions par le tiret
correspondant.

Dans le Tableau 2 ci-après, A et B représentent du texte en lettres de A à Z ou des chiffres de 0 à
9.
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Il  est  également  possible  d'insérer  des  tirets  cadratins  ou  demi-cadratins  à  partir  du  menu
Insertion > Caractères spéciaux. Sélectionnez-y le caractère U+2013 ou U+2014.

Une troisième méthode utilise les raccourcis claviers. Ces raccourcis varient suivant votre système
d'exploitation.-

Astuce

Vous pouvez aussi enregistrer des macros pour insérer des tirets demi-cadratins et
cadratins et assigner ces macros à des combinaisons de touches non utilisées, par
exemple  Ctrl+Maj+N et  Ctrl+Maj+M.  Pour  plus  d'informations  sur  les  macros,
référez-vous au chapitre 16, Personnaliser Writer, de ce guide.

Tableau 2 : Insérer des tirets.

Texte que vous saisissez Résultat

A - B (A, espace, signe moins, espace, B) A – B (A, espace, tiret demi-cadratin, espace,
B)

A --  B  (A,  espace,  signe  moins,  signe  moins,
espace, B)

A – B (A, espace, tiret demi-cadratin, espace,
B)

A--B (A, signe moins, signe moins, B) A—B (A, tiret cadratin, B)

A-B (A, signe moins, B) A-B (inchangé)

A -B (A, espace, signe moins, B) A -B (inchangé)

A --B (A, espace, signe moins, signe moins, B) A –B (A, espace, tiret demi-cadratin, B)

Windows
Sur la plupart des versions non asiatiques de Windows, maintenez enfoncée l'une des touches
Alt de votre clavier et tapez sur le clavier numérique 0150 pour un tiret demi-cadratin ou 0151
pour un tiret cadratin. Le tiret apparaît quand vous relâchez la touche Alt.

Astuce

Sur  un  clavier  sans  pavé  numérique,  utilisez  la  touche  Fn (Fonction)  en
combinaison pour taper les chiffres (la touche Fn est habituellement à la droite de
la touche Ctrl gauche du clavier). 

Par exemple,  sur un clavier français, la combinaison pour un tiret demi-cadratin
serait Alt+Fn+,ji, et pour un tiret cadratin Alt+Fn+,jij.

Linux
Maintenez enfoncée la touche Compose de votre clavier et tapez deux tirets et un point pour
un  tiret  demi-cadratin  ou  trois  tirets  pour  un  tiret  cadratin.  Le  tiret  apparaît  lorsque  vous
relâchez la touche Compose. 

Astuce
La touche qui opère comme Compose varie suivant les distributions Linux. Elle est
habituellement  l'une  des  touches  Alt ou  Win, mais  peut  être  une  autre  touche
choisie par l'utilisateur. 

Mac OS X
Maintenez la touche  Option (Alt) et  tapez un tiret  pour un tiret  demi-cadratin.  Pour un tiret
cadratin utilisez Maj+Option+tiret. 
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Formater les paragraphes

Vous pouvez appliquer de nombreux formats aux paragraphes en utilisant les boutons de la barre
de  Formatage.  La  Figure  8 montre  la  barre  de  Formatage comme  une  barre  flottante,
personnalisée pour afficher uniquement les boutons pour le formatage des paragraphes. Si vous
avez activé le support des langues asiatiques ou le support pour les langues à script complexe,
deux  boutons  supplémentaires  apparaissent  :  Gauche  à  droite et  Droite  à  gauche.  Leur
apparence varie en fonction de votre système d'exploitation et du thème d'icônes sélectionné via le
menu Outils > Options > LibreOffice > Affichage.

Astuce

Il est vivement recommandé de préférer l'utilisation des  styles de paragraphes
plutôt qu'un formatage manuel, surtout lors de la rédaction de longs documents.
Pour plus d'informations sur les styles et comment les utiliser, référez-vous aux
chapitres 6 et 7 de ce guide.

Attention
Le  formatage  manuel (aussi  appelé  formatage  direct)  prend  le  dessus  par
rapport aux styles,  et vous ne pourrez plus effacer ce formatage manuel  en y
appliquant un style.

Pour supprimer un formatage manuel, sélectionnez le texte, effectuez un clic droit
et choisissez l'option Effacer le formatage direct dans le menu contextuel.

1 Fenêtre Style et 
formatage

5 Aligner à droite 10 (Dés)activer la numérotation
6 Justifié 11 (Dés)activer les puces

2 Appliquer le style 7 Interligne : 1 12 Réduire le retrait
3 Aligner à gauche 8 Interligne : 1.5 13 Augmenter le retrait
4 Centré 9 Interligne : 2 14 Boîte de dialogue de format de

paragraphe

Figure  8.  La  barre  de  Formatage,  affichant  les  icônes  pour  le  formatage  de
paragraphe.

La Figure 9 montre des exemples des différentes options d'alignement de texte.

Figure 9. Options d'alignement du texte.

Lors de l'utilisation de texte justifié, la dernière ligne est, par défaut, alignée à gauche ; cependant,
si vous le souhaitez, vous pouvez également aligner la dernière ligne au centre de la zone de
paragraphe ou la justifier de façon à ce que des espaces soient insérés entre les mots de façon à
remplir toute la ligne. Si vous cochez l'option Étirer un seul mot, à chaque fois que la dernière
ligne d'un texte justifié ne contiendra qu'un seul mot, ce dernier sera étendu afin de remplir la ligne
entière. La Figure 10 montre un exemple des effets obtenus avec chacune des options possibles.
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Figure 10. Quatre choix disponibles pour la dernière ligne d'un paragraphe justifié.

Ces options sont disponibles dans l'onglet Alignement de la boîte de dialogue Paragraphe (voir
Figure 11), accessible via le menu  Format > Paragraphe ou en effectuant un clic droit sur le
paraphe à modifier et en choisissant Paragraphe dans le menu contextuel.

Figure 11. Options pour la dernière ligne d'un paragraphe justifié.

Définir des tabulations et des retraits
La règle horizontale affiche à la fois les tabulations par défaut ainsi que toutes les tabulations que
vous avez définies. Les paramètres d'une tabulation affectent le retrait d'un paragraphe entier (en
utilisant les icônes Augmenter le retrait et  Réduire le retrait de la barre de Formatage) et les
tabulations présentes dans un paragraphe (en appuyant sur la touche Tab de votre clavier).

L'utilisation de l'intervalle de tabulation par défaut peut causer des problèmes dans la mise en
page de votre document si vous le partagez avec d'autres personnes. En effet, si vous employez
l'intervalle de tabulation par défaut et que le destinataire de votre document a choisi un intervalle
de tabulation par défaut différent du vôtre, vos tabulations seront modifiées selon les paramètres
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du destinataire. Par conséquent, au lieu de recourir aux tabulations par défaut, il est préférable que
vous définissiez vos propres tabulations comme décrit dans cette section.

Pour paramétrer les tabulations et les retraits d'un ou plusieurs paragraphes sélectionnés, double-
cliquez dans la partie blanche de la règle horizontale afin d'ouvrir l'onglet Tabulations de la boîte
de dialogue Paragraphe ou double-cliquez dans les parties grisées (gauche ou droite) de la règle
horizontale pour ouvrir l'onglet Retraits et espacement de la même boîte de dialogue.

Figure 12. Définir la position des tabulations et les caractères de remplissage.

Une meilleure alternative consiste à définir les tabulations pour le style de paragraphe. Pour plus
d'informations sur les styles, référez-vous aux chapitres 6 et 7 de ce guide.

Astuce
Utiliser  des  tabulations  pour  espacer  des  éléments  sur  un  document  n'est  pas
recommandé. En fonction de ce que vous essayez de réaliser,  un tableau sans
bordure peut s'avérer être un meilleur choix que l'utilisation de tabulations.

Définir vos propres tabulations et retraits

Remarque

Toute modification apportée à l'intervalle de tabulation par défaut affectera tous les
intervalles de tabulation présents dans n'importe quel document créé auparavant.
De la même façon, toute nouvelle tabulation insérée après la modification sera
également affectée.
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Pour configurer l'Unité de mesure ainsi que l'Espace entre les tabulations par défaut, cliquez
sur le menu Outils > Options > LibreOffice Writer > Général.

Figure 13. Paramétrer l'espace par défaut entre les tabulations.

Vous pouvez également  paramétrer  l'Unité de mesure des règles  dans le  document  actif  en
effectuant un clic droit sur l'une des règles pour afficher la liste des unités de mesure (voir Figure
14). Cliquez sur l'unité de mesure désirée pour l'activer.  À noter que l'unité de mesure choisie
s'applique uniquement à la règle sur laquelle vous avez l'avez activée.

Figure  14.  Modifier  l'unité  de  mesure
depuis la règle horizontale.

Formater les caractères

Vous pouvez appliquer de nombreux formats de caractères en utilisant les boutons de la barre de
Formatage. La  Figure  15 montre  la  barre  de  Formatage comme  une  barre  flottante,
personnalisée  pour  afficher  uniquement  les  boutons  pour  le  formatage  des  caractères.
L'apparence des icônes peut varier en fonction de votre système d'exploitation ainsi que de votre
choix du style et de la taille des icônes (via le menu Outils > Options > LibreOffice > Affichage).

Il est vivement recommandé d'utiliser les  styles de caractères plutôt qu'un formatage manuel.
Pour plus d'informations sur les styles et comment les utiliser, référez-vous aux chapitres 6 et 7 de
ce guide.

1 Fenêtre Styles et formatage 7 Soulignage 13 Surligner

2 Appliquer le style 8 Exposant 14 Couleur d'arrière-plan

3 Nom de police 9 Indice 15 Ouvrir la boîte de dialogue 
Format4 Taille de police 10 Agrandir la police

5 Gras 11 Réduire la police

6 Italique 12 Couleur de la police

Figure 15. Barre de formatage affichant les icônes de formatage des caractères.
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Astuce

Vous pouvez supprimer un formatage manuel de trois manières : sélectionnez le
texte et cliquez sur le menu Format > Effacer le formatage direct ; sélectionnez
le texte, effectuez un clic droit puis cliquez sur l'option Effacer le formatage direct
dans le menu contextuel ; sélectionnez le texte et appuyez sur les touches Ctrl+M
de votre clavier.

Formatage automatique

Vous pouvez paramétrer Writer pour formater automatiquement certaines parties d'un document
en  définissant  certains  critères  dans  la  boîte  de  dialogue  AutoCorrection  (onglet  Options)
accessible via le menu Outils > AutoCorrection.

Figure 16. Choix de formatages automatiques dans la boîte de dialogue AutoCorrection.

L'Aide décrit chacun de ces choix et comment activer les formatages automatiques. Certaines
modifications communes non souhaitées et inattendues incluent : 

• Les  lignes  horizontales.  Si  vous  saisissez  trois  tirets  ou  plus  (---),  des  traits  de
soulignements (_ _ _) ou des signes égal (===) sur une ligne et appuyez ensuite sur la
touche Entrée de votre clavier, le paragraphe est alors remplacé par une ligne horizontale
aussi large que la page moins le retrait du paragraphe précédent pour lequel la ligne est la
bordure inférieure.

• Listes à puces et numérotées. Une liste à puces est créée lorsque vous saisissez un tiret
(-), un astérisque (*) ou le signe plus (+), suivi par un espace ou une tabulation au début
d'un paragraphe. Une liste numérotée est créée lorsque vous saisissez un nombre suivi
par un point (.),  suivi par un espace ou une tabulation au début  d'un paragraphe. Une
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numérotation  automatique  est  appliquée  aux  paragraphes  formatés  avec  les  styles  de
paragraphe Standard, Corps de texte ou Retrait de corps de texte. 

Astuce
Si  vous  remarquez  une  modification  de  formatage  inattendue,  c'est  le  premier
endroit où en chercher la cause.

Pour (dés)activer le formatage automatique,  cliquez sur le menu  Format > AutoCorrection et
(dé)cochez les éléments dans le sous-menu.

Pendant la frappe
Cette option permet de formater automatiquement le document pendant que vous tapez.

Appliquer
Cette option permet de formater automatique le document si l'option  Pendant la frappe est
désactivée.

Appliquer et éditer les modifications
Cette option permet de formater automatiquement le document et ouvre ensuite la boîte de
dialogue où vous pouvez accepter ou rejeter les modifications.

Options d'AutoCorrection

Cliquer sur cette option permet d'ouvrir la boîte de dialogue AutoCorrection (voir Figure 16).

Créer des listes à puces et numérotées

Il y a plusieurs façons de créer des listes numérotées ou des listes à puces :

• Utiliser le formatage automatique.

• Utiliser les styles de listes, comme ci-après et décrit dans les chapitres 6 et 7 de ce guide.

• Utiliser les icônes  Numérotation et  Puces dans la barre de  Formatage  (voir Figure 8).
Cette méthode est décrite dans cette section.

Pour produire une liste numérotée ou à puces, sélectionnez les paragraphes de la liste et cliquez
sur l'icône appropriée dans la barre d'outils.

Remarque
Que  vous  saisissiez  les  informations  en  premier  puis  appliquiez  la
numérotation/les puces, ou que vous appliquiez la numérotation/les puces lors de
la saisie est une question de préférence personnelle.

Utilisez la barre d'outils Puces et numérotation
Vous pouvez créer  des listes imbriquées (où un élément  d'une liste ou plus a une sous-liste,
comme dans un plan) en utilisant les boutons de la barre d'outils  Puces et numérotations (voir
Figure 17). Vous pouvez déplacer les éléments vers le bas ou le haut, ou créer des sous-points ou
même  modifier  le  style  de  la  puce.  Utilisez  Affichage  >  Barres  d'outils  >  Puces  et
numérotations pour afficher la barre d'outils.

Astuce
Il est possible de déplacer une entrée de liste vers le haut, en même temps que
toutes ses sous-entrées. Effectuez cela en appuyant sur le bouton  Hausser d'un
niveau (sous-points inclus). 
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1 (Dés)activer les puces 6 Hausser d'un niveau (sous-points 
inclus)

11 Déplacer vers le haut (sous-
points inclus)2 (Dés)activer la 

numérotation 7 Abaisser d'un niveau (sous-points 
inclus)

12 Déplacer vers le bas (sous-
points inclus)3 Désactiver la 

numérotation 8 Insérer une entrée sans numéro 13 Recommencer la 
numérotation4 Hausser d'un niveau 9 Déplacer vers le haut

5 Abaisser d'un niveau 10 Déplacer vers le bas 14 Puces et numérotation

Figure 17. Barre d'outils Puces et numérotation.

Si vous avez créé une liste imbriquée en utilisant les styles prédéfinis, tous les niveaux de la liste
(jusqu'à  10)  appliquent  la  même  numérotation  (ou  puces).  Cependant,  dans  bien  des
circonstances, vous souhaiterez utiliser une combinaison de formats de numérotation et de puces
lors  de  l'utilisation  de  listes  imbriquées.  De  telles  listes  avec  une  imbrication  de  formats  de
numérotations  et  de  puces  peuvent  facilement  être  configurées  comme décrit  dans  l'exemple
suivant. Pour plus d'informations sur les listes, et en particulier la technique pour créer vos propres
listes, référez-vous au chapitre 7, Travailler avec les styles, de ce guide. 

Astuce

Lorsque vous créez des listes imbriquées, une option consiste à saisir tous les
paragraphes de la liste et d'appliquer ensuite les niveaux. 

Vous pouvez utiliser les raccourcis claviers pour déplacer les paragraphes vers le
bas  ou  vers  le  haut  du  plan.  Placez  le  curseur  au  début  des  paragraphes
numérotés et appuyez sur les touches :

Tab Abaisser d'un niveau

Maj+Tab Hausser d'un niveau

Pour insérer une tabulation au début d'un paragraphe numéroté (c'est à dire après
le numéro mais avant le texte) appuyez sur les touches Ctrl+Tab de votre clavier. 

Exemple : configurer une liste imbriquée
Nous allons utiliser un style pour produire l'effet suivant :

  I.  Niveau-1 élément de liste

      A. Niveau-2 élément de liste

           i. Niveau-3 élément de liste

              a) Niveau-4 élément de liste

Cet exemple utilise l'un des styles par défaut, Numérotation 1. Cependant, si vous avez l'intention
de réutiliser ce type de liste imbriquée avec une présentation différente, vous pouvez aussi créer
un nouveau style comme expliqué dans le chapitre 7, Travailler avec les styles, de ce guide.

1) Ouvrez la fenêtre Styles et formatage et cliquez sur l'icône Styles de listes (voir Figure
18).  Dans la  liste  déroulante  située au bas de la  fenêtre,  choisissez  Tous les styles.
Effectuez ensuite un clic droit sur le style Numérotation 1 et cliquez sur Modifier dans le
menu contextuel.
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Figure 18. Modifier un style de liste.

2) Dans la boîte de dialogue Style de numérotation, cliquez sur l'onglet Plan (voir Figure 19)
où vous trouverez celui qui correspond à notre exemple. Sélectionnez-le.

Figure 19. Choisir un style de plan numéroté pré-défini.

3) Pour modifier la structure d'une liste, modifiez les paramètres de l'onglet  Options (voir
Figure  20).  La  partie  droite  affiche un aperçu du plan sélectionné.  À gauche,  dans la
colonne  Niveau,  cliquez  sur  1,  puis  sur  2,  3 et  4 afin  de  visualiser  les  informations
indiquées  dans  les  champs  Numérotation et  Derrière.  Dans  cet  onglet,  vous  pouvez
paramétrer les différents signes de ponctuation. Par exemple, au niveau  4, vous pouvez
préférer un point au lieu d'une parenthèse.

Dans l'onglet  Position (voir  Figure 21), il vous est possible d'agrandir ou de réduire le(s)
retrait(s)  de  chaque  niveau  de  titre.  Sélectionnez  le  niveau  concerné  dans  la  colonne
Niveau, puis modifiez sa position (retrait, tabulation, alignement, espacement, etc.).

4) Une  fois  les  modifications  apportées,  cliquez  sur  le  bouton  OK pour  appliquer  les
modifications et fermer la boîte de dialogue.
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Figure 20. L'onglet Options qui permet de visualiser ou modifier la structure d'une
numérotation.

Figure 21. L'onglet Position qui permet de visualiser ou modifier l'emplacement 
d'un niveau de titre.

Astuce

Grâce au plan de numérotation, vous pouvez définir des styles de puces différents
pour  les  différents  niveaux d'une liste  de  puces.  Pour  choisir  le  style  de  base,
cliquez  sur  l'onglet  Puces de  la  boîte  de  dialogue  Puces  et  numérotation
(accessible  via  le  menu  Format  >  Puces  et  numérotation).  Vous  pouvez
également choisir le style de caractère à utiliser dans votre liste (option  Style de
caractère).

Pour obtenir des styles de puces supplémentaires, cliquez sur l'onglet Images de la
boîte de dialogue Puces et numérotation.

Utiliser les notes de bas de page et les notes de fin

Les notes de bas de page apparaissent au bas de la page sur laquelle elles sont référencées. Les
notes de fin sont regroupées à la fin du document.

Pour travailler de manière efficace avec les notes de bas de page et les notes de fin, vous devez
pouvoir :

• insérer des notes de bas de page ;

• définir le format des notes de bas de page ;

• déterminer sur la page l'emplacement des notes, ainsi que la couleur et le style de ligne
des séparateurs.

Insérer des notes de bas de page/de fin
Pour insérer une note de bas de page ou une note de fin, placez le curseur de la souris à l'endroit
où vous souhaitez que l'ancre de note de bas de page/de fin apparaisse. Sélectionnez ensuite
Insertion > Note de bas de page/de fin dans la barre de menu ou cliquez sur l'icône  Insérer
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directement une note de bas de page ou  Insérer directement une note de fin dans la barre
d'outils Insérer (voir Figure 22).

Une ancre de bas de page (ou de fin) est insérée dans le texte, et le curseur de la souris est
déplacé dans la zone de note de bas de page en bas de la page (ou à la zone de note de fin à la
fin du document). Saisissez le contenu de la note de bas de page ou de fin dans cette zone. 

Figure  22.  L'icône Insérer  directement  une note  de bas de page/de fin  dans la  barre d'outils
Insérer.

Si vous passez par le menu Insertion > Note de bas de page/de fin, la boîte de dialogue Insérer
une note de bas de page/de fin s'ouvre (voir  Figure 23).  Vous pouvez y choisir  d'utiliser  la
séquence de numérotation automatique spécifiée dans les paramètres de la note de bas de page
ou encore, d'insérer l'élément comme une note de bas de page ou une note de fin.

Si vous utilisez l'icône  Insérer directement une note de bas de page ou  Insérer directement
une note de fin, la note de bas de page ou la note de fin prend automatiquement les attributs
définis précédemment dans la boîte de dialogue  Paramètres de note de bas de page/de fin
(accessible via le menu Outils > Notes de bas de page/de fin).

Vous pouvez éditer une note de bas de page/de fin existante de la même façon que vous éditez
tout autre texte. 

Pour supprimer une note de bas de page/de fin, supprimez son ancre. Le contenu de la note de
bas de page/de fin est supprimé automatiquement et la numérotation des autres notes de bas de
page/de fin est ajustée automatiquement. 

Figure 23. Boîte de dialogue Insérer une note 
de bas de page/de fin.

Définir le format des notes de bas de page/de fin
Pour formater automatiquement les notes de bas de page/de fin, cliquez sur le menu  Outils >
Notes de bas de page/de fin.  Dans la  boîte  de dialogue  Paramètres de notes de bas de
page/de fin (voir Figure 24), définissez vos préférences.

Définir l'emplacement d'une note de bas de page et le trait de séparation
Le style de page définit l'emplacement des notes de bas de page dans un document ainsi que la
couleur et le style du trait  de séparation. Si vous insérez des notes de bas de page dans un
document contenant des styles de pages différents, vous devez paramétrer l'emplacement des
notes ainsi que le style du trait de séparation pour chaque style de page.

Pour  afficher la boîte de dialogue  Style de page,  cliquez sur le  menu  Format > Page.  Vous
pouvez également effectuer un clic droit sur une page et choisir  Page dans le menu contextuel.
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Une fois la boîte de dialogue  Style de page ouverte, cliquez sur l'onglet  Note de bas de page
(voir Figure 25) et définissez vos préférences.

Figure 24. Définir le format d'une note de bas de page/de fin.

Figure 25. Définir l'emplacement d'une note de bas de page et le trait de séparation.

Modifier les notes de bas de page en note de fin et vice versa

Pour modifier une note de bas de page en note de fin (et vice versa), faites un clic droit sur l'ancre
de la note de bas de page/de fin et sélectionnez  Note de bas de page/de fin dans le menu
contextuel. Cela ouvre une boîte de dialogue dans laquelle des modifications peuvent être faites. 
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Vérification orthographique et grammaticale

Orthographe
Writer fournit un vérificateur orthographique qui contrôle chaque mot du document par rapport à
ceux enregistrés dans le  dictionnaire.  Cela signifie  que certains mots (par  exemple,  les noms
propres), même s'ils sont correctement orthographiés, peuvent être signalés comme mal écrits car
ils  ne  sont  pas  disponibles  dans  le  dictionnaire.  Writer  fournit  également  un  vérificateur
grammatical  qui  peut  être  utilisé  séparément  ou  en  combinaison  avec  le  vérificateur
orthographique (voir les sections Orthographe et grammaire et Grammaire en pages 27 et 29).

Si elle est  activée avant de commencer la saisie,  la fonction  Vérification automatique vérifie
chaque mot pendant la frappe. Si la fonction est activée après la saisie, tout le texte déjà présent
dans le document est vérifié. Les mots non reconnus sont soulignés par des vagues rouges.

La fonction Vérification automatique peut être activée en cliquant sur l'icône  dans la barre
d'outils Standard, ou via le menu Outils > Options > Paramètres linguistiques > Linguistique
puis en cochant l'option Vérifier l'orthographe au cours de la frappe dans la liste Options.

Faites un clic  droit  sur  un mot  non reconnu pour  ouvrir  un  menu contextuel (voir  Figure 26).
Cliquez ensuite sur l'une des suggestions dans le haut du menu pour remplacer le mot souligné
par celui que vous avez choisi.

Figure  26.  Menu  contextuel
pour la correction.

Plusieurs  choix  sont  disponibles  dans  le  centre  du  menu  contextuel dédié  à  la  correction
orthographique.

Ignorer
Le mot souligné sera ignoré tant que le document sera ouvert. Si le même mot est présent
ailleurs  dans le  document,  il  demeurera  souligné.  Ce  paramètre  n'est  pas  stocké  avec le
document.

Tout ignorer
Tous les mots identiques à celui souligné seront ignorés et le mot sera ajouté à la liste Tout
ignorer du dictionnaire personnalisé de l'utilisateur.

Ajouter
Le mot est ajouté au dictionnaire personnalisé de l'utilisateur. Si un seul dictionnaire est activé,
aucun choix n'est possible et le mot est par défaut ajouté au dictionnaire Standard.
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AutoCorrection
Ouvre un sous-menu qui reprend les suggestions du haut du menu. Le fait de sélectionner un
mot  de  remplacement  dans  ce  sous-menu  stocke  le  mot  en  question  dans  la  table  de
remplacement (disponible via le menu Outils > Options d'AutoCorrection > Remplacer). Par
conséquent, lorsque vous saisirez le mot mal orthographié dans n'importe quel document, il
sera  automatiquement  remplacé,  car  le  mot  mal  orthographié  et  son équivalence  correcte
seront  enregistrés  dans la  table  de remplacement.  Par  exemple,  si  vous saisissez le  mot
"voulior", il sera automatiquement remplacer par "vouloir".

Orthographe et grammaire
Cette  fonction  ouvre  la  boîte  de  dialogue  Orthographe  et  Grammaire.  Pour  plus
d'informations  sur  cette  boîte  de  dialogue,  consultez  la  section  suivante  Orthographe  et
grammaire en page 27.

Remarque

Si  aucun dictionnaire  grammatical  n'est  installé  sur  votre ordinateur,  la  boîte  de
dialogue  Orthographe  et  Grammaire s'intitulera  Orthographe.  Vous  pouvez
installer un dictionnaire grammatical via le menu Outils > Langue > Dictionnaires
supplémentaires  en  ligne.  Pour  plus  d'informations  sur  l'installation  de
dictionnaires ou d'extensions, référez-vous au chapitre 2,  Paramétrer Writer, de ce
guide.

Dans la troisième partie du menu contextuel dédié à la correction orthographique, vous pouvez
déterminer les paramètres linguistiques. Ces derniers peuvent s'appliquer au texte sélectionné, au
paragraphe ou au document entier.

Orthographe et grammaire
Pour effectuer une vérification du document (ou d'une sélection) combinant  l'orthographe et la

grammaire, cliquez sur l'icône Orthographe et grammaire  de la barre d'outils  Standard ou
appuyez sur la touche F7 de votre clavier. Afin de procéder à cette vérification, les dictionnaires
appropriés doivent être installés. Par défaut, quatre dictionnaires sont installés : un vérificateur
orthographique,  un  vérificateur  grammatical,  un  dictionnaire  de  césure  et  un  dictionnaire  des
synonymes. 

Si  aucun  texte  n'est  sélectionné,  la  vérification  orthographique  et  grammaticale  commence  à
l'endroit où le curseur est placé Si des mots non reconnus par le(s) dictionnaire(s) sont trouvés ou
qu'une règle grammaticale n'est pas respectée, la boîte de dialogue Orthographe et grammaire
s'ouvre (voir  Figure 27).  Lorsque la  vérification  est  terminée,  un message s'affiche pour  vous
proposer de recommencer la vérification depuis le début du document
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Figure 27. La boîte de dialogue Orthographe et grammaire.

Les éléments de la boîte de dialogue Orthographe et grammaire sont décrits ci-après.

Absent du dictionnaire
La  phrase  contenant  l'erreur  est  affichée  dans  le  champ.  Le  mot  non  reconnu  par  le
dictionnaire est affiché en rouge. Si une erreur grammaticale est remarquée, elle est indiquée
en bleu (voir Figure 30). La phrase ou le mot peut être directement modifié dans le champ.

Suggestions
Ce  champ  contient  les  suggestions  permettant  de  remplacer  le  mot  mal  orthographié.
Sélectionnez un mot et cliquez ensuite sur Modifier ou Tout modifier pour le remplacer. Pour
les erreurs grammaticales, il n'existe pas de choix multiple. Cliquez, si possible, sur Modifier
pour accepter la suggestion.

Langue du texte
La langue à utiliser pour la vérification orthographique et grammaticale peut être définie depuis
cette liste. Si la vérification orthographique est disponible pour cette langue, une coche est
affichée en face du nom de la langue.

Ignorer une fois, Ignore tout et Ajouter
Cliquer sur l'un de ces boutons a le même effet que de cliquer sur l'option  AutoCorrection
dans le menu contextuel dédié à la correction orthographique (voir la section Orthographe en
page 26).

Modifier
Remplace le mot non reconnu par le mot suggéré. Si la phrase a été éditée, l'intégralité de la
phrase est modifiée.

Modifier tout
Remplace dans le document tous les mots identiques à celui en rouge par le mot choisi dans
les suggestions.

AutoCorrection
Le bouton AutoCorrection de la boîte de dialogue Orthographe et grammaire se comporte
de  façon  similaire  à  l'option  AutoCorrection du  menu  contextuel  dédié  à  la  correction
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orthographique  (voir  la  section Orthographe en  page  26).  Cependant,  le  mot  n'est  pas
remplacé dans le document et vous devez donc recourir  au bouton  Modifier ou au bouton
Tout modifier.

Annuler
Ce bouton devient actif lorsqu'une modification a été effectuée dans la phrase, ce qui vous
permet d'annuler le changement.  Ce bouton n'est pas disponible si  vous utilisez le bouton
Modifier ou le bouton Tout modifier pour remplacer un mot.

Options
Ouvre la boîte de dialogue Options dans laquelle vous pouvez sélectionner les dictionnaires et
définir les paramètres de vérification orthographique et grammaticale.

Remarque
Il  est  conseillé  d'exécuter  deux  fois  pour  le  même  document  la  vérification
orthographique et grammaticale. Un problème mineur du logiciel peut empêcher la
détection de toutes les erreurs grammaticales en un seul passage.

Grammaire
Par défaut, la fonction  Vérifier la grammaire au cours de la frappe est activée dans le menu
Outils > Options > Paramètres linguistiques > Options.

La vérification orthographique doit être activée pour que la vérification grammaticale fonctionne.

Si des erreurs sont détectées, elles sont soulignées par des vagues bleues. Effectuez un clic droit
sur l'erreur afin d'afficher un menu contextuel semblable à celui affiché en Figure 28 et Figure 29.

La première entrée du menu vous renseigne sur la règle grammaticale suspectée de ne pas être
respectée.

Dans l'exemple de la Figure 28, la seconde entrée du menu Explications ouvre votre navigateur
internet  et  vous présente un site web vous indiquant  de plus amples informations sur l'erreur
commise.
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La seconde section du menu vous suggère des corrections possibles. Cliquez sur l'une de ces
suggestions  pour  modifier  l'erreur  par  ladite  suggestion.  Dans  l'exemple  de  la  Figure  29,  la
seconde section est vide, mais vous pouvez cliquer sur cette ligne vide pour supprimer le double
espace responsable de l'erreur.

Dans la troisième section du menu, vous pouvez choisir d'ignorer l'erreur indiquée ou ouvrir le
vérificateur orthographique et grammatical. La Figure 30 montre la boîte de dialogue Orthographe
et grammaire expliquant l'erreur grammaticale commise.

Figure  30.  La  boîte  de  dialogue  Orthographe  et  grammaire  donnant  des
informations sur l'erreur grammaticale commise.

Dans la dernière section du menu, vous pouvez paramétrer  la  langue pour  la  sélection ou le
paragraphe.

Vous pouvez également ajouter des correcteurs grammaticaux supplémentaires en ajoutant des
extensions  via  le  Gestionnaire  des  extensions (via  le  menu  Outils >  Gestionnaire  des
extensions).

Utiliser les outils linguistiques intégrés

Writer fournit quelques outils qui pourraient faciliter votre travail si vous utilisez plusieurs langues
dans un même document ou si vous rédigez des documents dans de nombreuses langues :

• la sélection des styles de paragraphes et de caractères,

• les fonctions disponibles via le menu Outils > Langue,

• les paramètres linguistiques dans les options,

• les fonctions proposées dans la barre d'état.

Le principal avantage de modifier la langue pour une sélection réside dans le fait que vous pouvez
ensuite utiliser les dictionnaires adéquats afin de vérifier l'orthographe et la grammaire, appliquer
les tables de remplacement de l'AutoCorrection, les synonymes ainsi que les règles de césure
adaptés à la langue définie.
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Vous pouvez également définir  la langue pour un paragraphe ou un groupe de caractères sur
Aucune  (pas  de  vérification  orthographique).  Cette  option  est  utile  dans  le  cas  où  vous
saisissez du texte tel que des liens internet ou du langage de programmation.

Utiliser les styles de paragraphes et de caractères
La  meilleure  méthode  consiste  à  paramétrer  la  langue  pour  les  styles  de  caractères  et  de
paragraphes. En effet, l'utilisation des styles implique une meilleure gestion des langues et facilite
les éventuelles modifications ce celles-ci.

Dans la  boîte de dialogue  Styles et  formatage (onglet  Styles de paragraphe),  vous pouvez
définir  quels  seront  les  (quelques)  paragraphes  rédigés  dans  une  langue  différente  que  celle
paramétrée pour le reste du document.

Pour plus d'informations sur la façon de paramétrer la langue d'un style, référez-vous au chapitre
7, Travailler avec les styles, de ce guide.

Utiliser le menu Outils > Langue
Via le menu Outils > Langue, vous pouvez définir la langue pour tout le document, pour quelques
paragraphes ou certains mots et caractères.

Pour la sélection
Appliquer la langue choisie au texte sélectionné.

Pour le paragraphe
Appliquer la langue choisie au paragraphe où le curseur de la souris se situe.

Pour tout le texte
Appliquer la langue choisie à tout le document, y compris au texte saisi après avoir déterminé
la langue.

Utiliser les paramètres linguistiques dans les options
Il  est possible de modifier la langue pour le document entier via le menu  Outils > Options >
Paramètres linguistiques > Langues.  Dans la section  Langues par défaut des documents
(voir  Figure 31), vous pouvez choisir  une langue différente pour le texte qui n'a pas été défini
explicitement comme une langue différente.

Attention

Contrairement à l'option de la barre des menus qui applique la modification à un
document individuel, un changement effectué dans la section Langues par défaut
des documents de la boîte de dialogue Options s'applique à tous les documents
en cours ainsi  qu'à  tous ceux qui  seront  créés dans le  futur,  car  il  s'agit  d'un
paramètre général de LibreOffice. Si vous souhaitez modifier la langue pour le
document actif uniquement, assurez-vous d'avoir bien coché l'option Uniquement
pour le document actif.
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Figure 31. Options disponibles dans les Paramètres linguistiques.

La vérification orthographique et grammaticale fonctionne uniquement avec les langues qui sont

indiquées avec le symbole  dans la liste (voir Figure 31). Si vous ne voyez pas ce symbole à
côté de la langue choisie, il vous est possible d'installer les dictionnaires nécessaires via le menu
Outils > Langue > Dictionnaires supplémentaires en ligne.

Utiliser la barre d'état
La langue utilisée pour la vérification orthographique et grammaticale est également indiquée dans
la barre d'état, à droite du style de page utilisé. Via la barre d'état, il vous est possible de modifier
la langue pour un paragraphe ou pour le document entier. Pour ce faire, cliquez sur la langue dans
la barre d'état afin d'ouvrir un menu contenant les différents choix disponibles.

Figure  32. Choisir  les langues du document/paragraphe via la barre
d'état.

À noter  que  l'option  Rétablir  la  langue  par  défaut est  disponible  aussi  bien  dans  le  menu
(document entier) que dans le sous-menu (paragraphe). Il s'agit de la façon la plus rapide afin de
rétablir, pour le document entier ou pour un paragraphe, la langue par défaut paramétrée dans le
menu Outils > Options > Paramètres linguistiques > Langues.

Utiliser le dictionnaire des synonymes

Vous pouvez obtenir une courte liste des synonymes possibles via le menu contextuel (voir Figure
18):

1) Effectuez  un  clic  droit  sur  un  mot  ou  une  phrase  sélectionnée  afin  d'ouvrir  le  menu
contextuel.  Placez  le  curseur  de  la  souris  sur  le  point  de  menu  Synonymes pour
développer le sous-menu dans lequel s'affichent des propositions alternatives au mot ou à
la phrase.

2) Cliquez sur un mot ou une phrase pour remplacer le mot ou la phrase concerné(e) dans
votre document.

Le Dictionnaire des synonymes fournit une liste plus étoffée de mots et de phrases alternatifs.
Pour utiliser le Dictionnaire des synonymes :

1) Sélectionnez un mot ou une phrase dans votre document. Cliquez ensuite sur le menu
Outils > Langue > Dictionnaire des synonymes, ou appuyez sur les touches Ctrl+F7 de
votre  clavier,  ou  faites  un  clic  droit  sur  la  sélection  et  choisissez  Synonymes >
Dictionnaire des synonymes dans le menu contextuel.

2) La boîte de dialogue Dictionnaire des synonymes s'affiche. Cliquez sur un mot ou une
phrase dans la liste des alternatives pour la sélectionner.
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3) Cliquez sur le bouton Remplacer pour effectuer la substitution.

Par exemple, si vous souhaitez remplacer le mot légal, le Dictionnaire des synonymes
proposera de nombreuses significations et alternatives dont vrai, inné et authentique (voir
Figure 34).

Figure  33.  Synonymes  disponibles  dans  le
menu contextuel.

Remarque
Si un Dictionnaire des synonymes n'est pas installé pour la langue active, cette
fonction est désactivée.
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Figure 34. La boîte de dialogue Dictionnaire des synonymes.

Coupure des mots

Vous  avez  plusieurs  choix  en  ce  qui  concerne  la  coupure  des  mots :  laisser  Writer  le  faire
automatiquement (grâce à son dictionnaire de coupure des mots), insérer manuellement des tirets
conditionnels où vous le souhaitez, ou ne pas couper les mots du tout. Chaque choix présente des
avantages et des inconvénients.

Coupure des mots automatique
Pour (dés)activer la coupure des mots automatique :

1) Appuyez sur la touche F11 de votre clavier pour ouvrir la fenêtre Style et formatage. Dans
l'onglet Styles de paragraphe, faites un clic droit pour ouvrir un menu contextuel. Cliquez
ensuite sur Modifier.

Figure  35 .  Modifier  un  style  de
paragraphe.
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2) Dans la boîte de dialogue Style de paragraphe, cliquez sur l'onglet Enchaînements.

Figure 36. Activer la coupure des mots automatique.

3) Sous la section Coupure des mots, (dé)cochez l'option Automatique.

4) Cliquez sur le bouton OK pour enregistrer les modifications.

Remarque

Activer la coupure des mots pour le style de paragraphe par défaut affecte tous les
paragraphes basés sur le style par défaut. Les styles non basés sur le style par
défaut, un style de titre par exemple, ne sera pas affecté par cette modification, à
moins que vous ne paramétriez également son style de paragraphe. Pour plus
d'informations sur les styles de paragraphe, référez-vous aux chapitres 6 et 7 de
ce guide.

Vous pouvez configurer les paramètres de coupure des mots via le menu  Outils > Options >
Paramètres linguistiques > Linguistique. Dans la section Options, recherchez les paramètres
relatifs à la coupure des mots.

 Figure 37. Paramètres relatifs à la coupure des mots.

Pour modifier le nombre minimum de caractères pour la coupure des mots ou le nombre minimum
de  caractères  avant/après  la  séparation,  sélectionnez  l'élément  concerné  puis  cliquez  sur  le
bouton Éditer. 

Coupure automatique
Indique qu'il ne vous sera jamais demandé de couper manuellement les mots non reconnus
par le dictionnaire de coupure des mots. Si cette case n'est pas cochée, lorsqu'un mot ne sera
pas reconnu, une boîte de dialogue s'ouvrira afin que vous réalisiez la coupure manuellement.

Coupure des zones spéciales
Indique que la coupure des mots sera également réalisée dans les notes de bas de page, les
en-têtes et les bas de page.

Les options inhérentes à la coupure des mots paramétrées dans le menu  Outils > Options >
Paramètres linguistiques > Linguistique sont effectives uniquement si la coupure des mots est
activée dans les styles de paragraphe.
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Coupure des mots manuelle
Lors d'une coupure des mots manuelle, n'utilisez pas un tiret normal. Ce dernier restera visible
même si le mot coupé n'est plus trop long en raison d'un ajout ou d'une suppression de texte,
d'une modification des marges ou de la taille de la police. Utilisez plutôt un Tiret conditionnel.

Pour insérer un Tiret conditionnel à l'intérieur d'un mot, cliquez dans le mot à l'endroit où vous
souhaitez que celui-ci apparaisse et enfoncez ensuite les touches  Ctrl+Tiret de votre clavier ou
cliquez sur le menu Insertion > Marque de formatage > Tiret conditionnel. Le mot sera coupé à
l'endroit  choisi  lorsqu'il  se  retrouvera  à  la  fin  d'une  ligne,  même  si  la  coupure  des  mots
automatique est désactivée pour le paragraphe.

Utiliser l'AutoCorrection

Les options d'AutoCorrection de Writer constituent une longue liste de fautes d'orthographe/de
frappe courantes et d'erreurs typiques qui peuvent être corrigées automatiquement. Par exemple,
“dse” sera remplacé par “des”.

Les options d'AutoCorrection sont activées par défaut. Pour les désactiver, décochez l'option via
le menu  Format > AutoCorrection > Pendant la frappe.

Pour  ouvrir  la  boîte  de  dialogue  AutoCorrection,  cliquez  sur  le  menu  Outils >  Options
d'AutoCorrection. Vous pouvez y définir quels sont les mots à corriger, le texte de remplacement
et le format à utiliser. À noter que de nombreuses entrées sont déjà disponibles.

Afin que Writer arrête de remplacer un mot mal orthographié, cliquez sur l'onglet Remplacer de la
boîte de dialogue AutoCorrection. Sélectionnez le mot mal orthographié et son remplaçant, puis
cliquez sur le bouton Supprimer.

Pour ajouter un nouveau mot à la liste, saisissez sa version mal orthographiée dans le champ
Remplacer ainsi que son remplaçant dans le champ Par. Cliquez ensuite sur le bouton Nouveau.

N'hésitez pas à également consulter les autres onglets de la boîte de dialogue  AutoCorrection
afin de découvrir toutes les autres options disponibles et, éventuellement, de les peaufiner.

Astuce

L'AutoCorrection peut  être  utilisée  comme  un  moyen  rapide  d'insérer  des
caractères spéciaux. Par exemple, (c) sera remplacé automatiquement par ©. Vous
pouvez également ajouter d'autres caractères spéciaux à la liste.

Un clic droit dans les zones  Remplacer et  Par permet d'accéder aux caractères
spéciaux.
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Figure 38. L'onglet Remplacer de la boîte de dialogue AutoCorrection.

Utiliser la complétion des mots

Si la  Complétion des mots est activée,  Writer  tente de déterminer quel est le mot que vous
saisissez et vous propose de compléter le mot pour vous. Pour accepter la suggestion du logiciel,
appuyez sur la touche Entrée de votre clavier. Si la suggestion ne vous convient pas, continuez à
saisir le mot.

Pour  désactiver  la  Complétion  des  mots,  cliquez  sur  le  menu  Outils >  Options
d'AutoCorrection > Insertion automatique puis décochez l'option  Activer la complétion des
mots.

Il est possible de personnaliser la complétion des mots via l'onglet  Insertion automatique de la
boîte de dialogue AutoCorrection.

• Ajouter un espace automatiquement après le mot que vous venez d'accepter.

• Afficher sous forme d'infobulle la suggestion plutôt que de l'afficher dans le texte que
vous saisissez.

• Rassembler les mots lorsque vous travaillez dans un document et les garder en mémoire
afin de les utiliser dans d'autres documents. Toutefois, vous pouvez décider de supprimer
la liste des mots lorsque vous fermerez le document.

• Modifier  le  maximum d'entrées à enregistrer  pour  la  complétion  des mots ainsi  que la
longueur minimum et maximum des mots à sauvegarder.

• Supprimer certaines entrées de la liste des mots disponibles pour la complétion.

• Modifier la touche qui vous permet d'accepter la suggestion. Les touches possibles sont :
Flèche vers la droite, Fin, Entrée, Barre espace et Tabulation.
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Remarque
La Complétion des mots s'active si vous avez saisi au moins deux fois le même
mot dans un même document.

Figure 39. Personnaliser la complétion des mots.

Utiliser l'AutoTexte

Les AutoTextes permettent d'enregistrer du texte, des tableaux, des champs ainsi que d'autres
éléments que vous utilisez de manières récurrentes. Vous pourrez les lier à des raccourcis qui
faciliteront leur récupération.

Par exemple, au lieu de chaque fois saisir la formule de politesse “Je vous prie d'agréer, Madame,
Monsieur, mes salutations distinguées.” dans un courrier, vous pouvez paramétrer un AutoTexte
afin de simplement saisir  le raccourci  “sd” et appuyer sur la touche  F3 pour insérer la phrase
complète dans votre document.

Les  AutoTextes  sont  particulièrement  utiles  lorsqu'ils  sont  assignés  à  des  champs.  Pour  plus
d'information sur les champs, référez-vous au chapitre 14, Travailler avec les champs, de ce guide.

Créer un AutoTexte
Pour enregistrer du texte comme AutoTexte :

1) Saisissez le texte dans votre document.

2) Sélectionnez le texte.

3) Cliquez sur le menu Édition > AutoTexte (ou appuyez sur les touches  Ctrl+F3  de votre
clavier).
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4) Dans la boîte de dialogue  AutoTexte, saisissez un nom pour l'AutoTexte dans le champ
Nom. Dans le champ  Raccourci, Writer vous suggérera un raccourci que vous pourrez
éventuellement modifier.

5) Dans la liste en dessous des champs  Nom et  Raccourci,  choisissez la catégorie dans
laquelle enregistrer l'AutoTexte. Par exemple, optez pour la catégorie Mes AutoTextes.

6) À droite de la boîte de dialogue, cliquez sur le bouton AutoTexte et sélectionnez, dans le
sous-menu, soit Nouveau (si vous souhaitez que votre AutoTexte conserve son formatage,
peu importe l'endroit où il sera inséré), soit Nouveau (texte seulement) (si vous souhaitez
que votre AutoTexte s'imprègne du formatage de l'emplacement où il sera inséré).

7) Cliquez sur le bouton Fermer pour retourner au document.

Figure 40. Définir une nouvelle entrée d'AutoTexte.

Astuce
Si la seule option possible dans le sous-menu du bouton AutoTexte est Importer,
soit  vous  n'avez  pas  donné  un  nom  à  l'AutoTexte,  soit  aucun  texte  n'a  été
sélectionné dans le document.

Pour enregistrer un tableau comme AutoTexte (par exemple, un tableau formaté comme l'astuce
ci-avant) :

1) Créez un tableau et formatez-le comme vous le souhaitez.

2) Sélectionnez le tableau.

3) Cliquez sur le menu Édition > AutoTexte (ou appuyez sur les touches  Ctrl+F3  de votre
clavier).

4) Dans la boîte de dialogue  AutoTexte, saisissez un nom pour l'AutoTexte dans le champ
Nom. Dans le champ  Raccourci, Writer vous suggérera un raccourci que vous pourrez
éventuellement modifier.

5) À droite de la boîte de dialogue, cliquez sur le bouton AutoTexte et sélectionnez, dans le
sous-menu, l'option Nouveau car vous souhaitez préserver le formatage du tableau.

6) Cliquez sur le bouton Fermer pour retourner au document.

Insérer un AutoTexte
Pour insérer un AutoTexte, saisissez le raccourci dans votre document et appuyez ensuite sur la
touche F3 de votre clavier.

Si, lors de la création de votre AutoTexte, vous avez coché l'option Lors de la saisie, afficher le
nom complet sous forme d'infobulle (voir  Figure 40), saisissez le nom de l'AutoTexte et une
infobulle fera son apparition. Dès que vous la verrez, appuyez sur la touche Entrée de votre clavier
pour insérer l'AutoTexte.
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Astuce
Il est possible d'insérer une image dans une entrée d'Autotexte, à la condition que
celle-ci soit précédée et suivie d'un caractère, une espace, par exemple.

Imprimer une liste des entrées d'AutoTexte
Pour imprimer une liste des entrées d'AutoTexte :

1) Cliquez sur le menu Outils > Macros > Gérer les macros > LibreOffice Basic.

2) Dans la liste Macro de, cliquez sur Macros LibreOffice > Gimmicks > AutoTexte.

3) Cliquez  sur  le  bouton  Exécuter.  Une  liste  des  entrées  d'AutoTexte  disponibles  sera
générée dans un nouveau document que vous pourrez ensuite imprimer.

Numérotation des lignes

La Numérotation des lignes permet de placer un numéro de ligne dans la marge du document.
Les numéros de lignes sont affichés à l'écran et sont également imprimables. La Figure 42 montre
un exemple de numérotation à chaque ligne.

Figure 42. Exemple de numérotation des
lignes.

Cliquez  sur  le  menu  Outils >  Numérotation  des  lignes et  cochez  l'option  Activer  la
numérotation en haut à gauche de la boîte de dialogue  Numérotation des lignes (voir  Figure
43).
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Figure 43. La boîte de dialogue Numérotation des lignes.

Vous pouvez paramétrer le nombre de lignes à numéroter (par exemple, chaque ligne ou bien
toutes les 10 lignes), le type de numérotation et si la numérotation doit recommencer à zéro sur
chaque  page.  En  outre,  une  ligne  de  séparation  peut  être  définie  sur  différents  niveaux  de
numérotation (par exemple, toutes les 12 lignes).

La numérotation peut être (dés)activée pour des paragraphes individuels (commande  Format >
Paragraphe onglet  Plan & numérotation) ou au niveau du style de paragraphe ce qui est la
méthode recommandée.

Suivre les modifications apportées à un document

Plusieurs méthodes sont possibles afin de suivre les modifications apportées à un document :

• Effectuez les modifications sur une copie du document (enregistré dans un dossier différent
ou sauvegardé sous un autre nom). Utilisez ensuite Writer pour combiner les deux fichiers
et vous montrer quelles modifications y ont été apportées. Pour ce faire, cliquez sur le
menu Édition > Comparer le document. Cette technique est particulièrement pratique si
vous êtes la seule personne à travailler sur le document. En effet, elle évite d'augmenter la
taille du fichier et s'avère moins complexe que les autres méthodes.

• Enregistrez différentes versions du document (à des moments distincts) qui seront toutes
stockées dans le fichier d'origine. Cette méthode peut toutefois entraîner des problèmes au
document à cause de la taille du fichier, en particulier si vous sauvegardez de nombreuses
versions. C'est pourquoi il vaut mieux, dans la mesure du possible, réserver cette méthode
aux documents courts ou peu modifiés.

• Utilisez  les  marques  de  révision  afin  d'afficher  clairement  les  modifications
(ajout/suppression de texte et changement de formatage). Plus tard, une autre personne
ou vous-même pourrez accepter ou rejeter les modifications apportées.

Remarque

Toutes  les  modifications  ne  peuvent  pas  être  enregistrées.  Par  exemple,  des
modifications apportées à un taquet de tabulation (changer l'alignement à gauche
en alignement à droite), à des formules (équations) ou à des graphiques ne peuvent
pas être mémorisées.
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Préparer un document pour la révision
Lorsque vous envoyez un document à quelqu'un pour relecture ou édition, préparez-le afin que le
destinataire  n'ait  pas  à  activer  les  marques  de  révision.  Une  fois  que  vous  aurez  protégé  le
document, n'importe quel utilisateur devra entrer un mot de passe afin de désactiver les marques
de révision et d'accepter ou rejeter les modifications.

1) Ouvrez le document et assurez-vous qu'il ne contient pas plusieurs versions. Pour ce faire,
cliquez  sur  le  menu  Fichier  >  Versions.  Si  plusieurs  versions  du  document  sont
répertoriées, enregistrez la version actuelle séparément (par exemple, dans un nouveau
dossier ou sous un nom différent) et utilisez ce nouveau document pour la révision.

2) Dans le  document  destiné à la  révision,  assurez-vous que la  fonction  Enregistrer  les
modifications soit  bien  activée.  Vérifiez  dans  le  menu  Édition >  Modifications  >
Enregistrer qu'une coche soit bien présente à côté de l'option Enregistrer.

3) Cliquez sur le menu Édition > Modifications > Protéger l'historique. Dans la boîte de
dialogue  Saisir le mot de passe, entrez un mot de passe, confirmez-le dans le second
champ et cliquez sur le bouton OK pour valider.

Astuce
Une alternative aux étapes 2 et 3 consiste à cliquer sur l'onglet Sécurité du menu
Fichier  > Propriétés. Cochez l'option  Enregistrer les modifications puis cliquez
sur le bouton Protéger pour entrer le mot de passe.

Enregistrer les modifications
Pour savoir comment modifier l'affichage des  marques de révision, référez-vous au chapitre 2,
Personnaliser Writer, de ce guide.

1) Pour  activer  l'enregistrement  des  modifications,  cliquez  sur  le  menu  Édition  >
Modifications > Enregistrer. Pour afficher ou cacher les marques de révisions, cliquez
sur le menu Édition > Modifications > Afficher.

Astuce

À l'aide de la souris, survolez une marque de révision afin d'afficher une infobulle.
Cette dernière vous indiquera le genre de la modification, l'auteur, la date ainsi que
l'heure à laquelle le changement a été effectué.

Si les infoballons sont activés, vous obtiendrez également tous les commentaires
relatifs à la modification.

2) Pour  insérer  un  commentaire  dans  une  zone  de  modification,  sélectionnez  le  texte
concerné à l'aide de la souris et cliquez ensuite sur le menu Édition  > Modifications  >
Commentaire.

En plus d'être affiché comme infoballon, le commentaire sera également visible parmi les
éléments répertoriés dans la boîte de dialogue  Accepter ou rejeter les modifications
(voir Figure 45).

Pour passer d'un commentaire à un autre, utilisez les touches fléchées de votre clavier. Si
aucun commentaire n'a été enregistré pour une modification, le champ Texte sera vide.

3) Pour arrêter l'enregistrement des modifications, cliquez à nouveau sur le menu Édition >
Modifications > Enregistrer.

Astuce
Pour annoter du texte sans avoir recours au suivi des modifications, consultez la
section Ajouter d'autres commentaires en page 45.
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Figure  44.  Insérer  un  commentaire  lorsque  les
modifications sont enregistrées.

Accepter ou rejeter les modifications
Pour accepter ou rejeter les modifications, utilisez l'une des méthodes suivantes :

• le clic droit pour ouvrir un menu contextuel ;

• la boîte de dialogue Accepter ou rejeter les modifications.

Les résultats d'une acceptation ou d'un rejet des modifications sont les suivants :

• accepter  une  modification  l'incorpore  au  document,  c'est-à-dire  que  du  texte  est
ajouté/supprimé, et les marques de révision disparaissent ;

• rejeter une modification permet au document de retrouver son état d'origine et les marques
de révision disparaissent.

Menu contextuel via le clic droit
1) Si  les  marques  de  révision  ne  sont  pas  visibles,  cliquez  sur  le  menu  Édition  >

Modifications > Afficher.

2) À l'aide de la souris, survolez une marque de révision afin d'afficher une infobulle qui vous
indiquera  le  genre  de  la  modification,  l'auteur,  la  date  ainsi  que  l'heure  à  laquelle  le
changement a été effectué.

3) Faites un clic droit sur le texte modifié. Dans le menu contextuel, cliquez sur Accepter la
modification ou Rejeter la modification.

Boîte de dialogue Accepter ou rejeter les modifications
1) Cliquez sur le menu Édition > Modifications > Accepter ou rejeter pour ouvrir la boîte de

dialogue Accepter ou rejeter les modifications (voir  Figure 45). L'onglet  Liste de cette
dernière répertorie les modifications qui n'ont pas encore été acceptées ou rejetées.

2) Lorsque vous cliquez sur une modification dans la boîte de dialogue, ladite modification est
surlignée  dans  le  document.  De  cette  façon,  il  vous  est  plus  facile  de  visualiser  le
changement dans son contexte.

3) Cliquez sur le bouton Accepter ou le bouton Refuser pour accepter/rejeter la modification
sélectionnée. Vous pouvez aussi cliquer sur le bouton Tout accepter ou  Tout refuser si
vous ne souhaitez pas consulter les modifications une par une.

Dans la boîte de dialogue Accepter ou rejeter les modifications, l'onglet Filtre (voir Figure 46)
permet  d'afficher  les  modifications  selon  des  critères  que  vous  déterminez  (par  exemple,  les
changements effectués par une personne en particulier). Une fois les paramètres entrés, retournez
à  l'onglet  Liste.  Les  modifications  qui  ne  correspondent  pas  à  vos  réglages  ne  sont  plus
proposées.
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Figure 45. L'onglet Liste de la boîte de dialogue Accepter ou rejeter les modifications.

Figure 46. L'onglet Filtre de la boîte de dialogue Accepter ou rejeter les modifications.

Fusionner les documents modifiés
Jusqu'à présent, les procédés exposés s'avèrent efficaces si les relecteurs travaillent chacun à
leur tour. Cependant, il peut arriver que plusieurs relecteurs renvoient leurs corrections en même
temps. Dans ce cas, il sera plus pratique de visualiser les corrections en une seule fois plutôt que
de les examiner une par une. C'est pourquoi il est important de pouvoir fusionner les documents
dans Writer.

Pour pouvoir fusionner les documents, la fonction Enregistrer les modifications doit être activée
dans les copies du document original.

1) Faites une copie du document à relire après vous être assuré que la fonction Enregistrer
les  modifications (via  le  menu  Édition >  Modifications  >  Enregistrer)  ait  bien  été
activée.

2) Envoyez la copie au(x) relecteur(s) qui vous la retournera(ont) corrigée.

3) Ouvrez la copie et cliquez sur le menu Édition > Modification > Fusionner le document.

4) Dans la boîte de dialogue Insérer, choisissez la copie renvoyée par le relecteur. Cliquez
ensuite sur le bouton Ouvrir.
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5) Après la fusion des deux documents, la boîte de dialogue  Accepter ou rejeter s'ouvre
(voir Figure 45).  Vous pouvez y visualiser les corrections apportées.  Si vous souhaitez
toutefois fusionner d'autres documents avant  d'accepter ou de rejeter les modifications,
fermez la boîte de dialogue et répétez les étapes 3 et 4 jusqu'à ce que toutes les copies
aient été fusionnées avec le document original.

6) Une  fois  que  toutes  les  modifications  auront  été  intégrées  dans  le  document,  il  est
vivement conseillé d'enregistrer le document sous un autre nom.

Comparer des documents
Parfois,  les relecteurs oublient d'activer la fonction  Enregistrer les modifications.  Pour pallier
cette  inattention,  Writer  vous  permet  de  comparer  des  documents  et  de  retrouver  ainsi  les
différences.

Pour comparer le document original et le document modifié :

1) Ouvrez le document modifié puis cliquez sur le menu Édition > Comparer le document.

2) La boîte de dialogue  Insérer s'ouvre. Sélectionnez le document original et cliquez sur le
bouton Ouvrir.

3) Writer  trouve et  met en évidence les modifications.  La boîte de dialogue  Accepter ou
rejeter s'ouvre. Vous pouvez alors accepter ou rejeter les modifications comme décrit dans
les sections précédentes.

Ajouter d'autres commentaires

Writer propose un autre type de commentaires que l'on pourrait appeler "notes" ou "pense-bêtes".
Les  auteurs  et  les  relecteurs  l'utilisent  fréquemment  pour  échanger  des  idées,  faire  des
suggestions, poser des questions ou lors d'une réunion remue-méninges.

Un commentaire peut  cibler  un bloc de texte ou un seul  point  du document.  Pour insérer  un
commentaire, sélectionnez le texte concerné ou placez votre curseur à l'endroit où vous souhaitez
faire  apparaître  le  commentaire.  Ensuite,  cliquez  sur  le  menu  Insertion >  Commentaire ou
appuyez  sur  les  touches  Ctrl+Alt+C de  votre  clavier.  Le  point  d'ancrage  du  commentaire  est
connecté par une ligne pointillée à un cadre situé à droite de la page et dans lequel vous pouvez
saisir le texte du commentaire. Writer indique automatiquement au bas du commentaire le nom de
l'auteur ainsi que le moment de sa création. La  Figure 47 montre un document sur lequel des
commentaires de deux auteurs différents ont été ajoutés.

Cliquez n'importe où dans la page, ou appuyez sur la touche Échap de votre clavier, pour indiquer
à Writer que vous avez terminé d'éditer le commentaire. Autrement, vous ne pourrez pas quitter le
cadre du commentaire.

Pour modifier le nom d'auteur qui apparaît dans le commentaire, cliquez sur le menu  Outils >
Options > LibreOffice > Données d'identité.

Si plus d'une personne édite le document, chaque auteur se voit allouer automatiquement une
couleur de fond différente.
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Figure 47. Les commentaires dans Writer.

Faites un clic droit dans un commentaire afin d'ouvrir un menu déroulant dans lequel vous pourrez
choisir de supprimer le commentaire actif, tous les commentaires d'un même auteur ou tous les
commentaires du document. Cette partie du menu déroulant est également accessible en cliquant
sur le bouton en bas à droite du commentaire. Depuis le menu déroulant, vous pouvez également
appliquer quelques formatages basiques au texte du commentaire. Il vous est également possible
d'utiliser les fonctions de la barre de formatage.

Pour passer d'un commentaire à un autre, ouvrez le Navigateur depuis la barre d'outils standard
ou appuyez sur la touche  F5 de votre clavier.  Développez le menu  Commentaires et  double-
cliquez sur un des commentaires pour déplacer le curseur au point d'ancrage du commentaire.

Vous pouvez également passer d'un commentaire à un autre en utilisant le clavier. Appuyez sur les
touches  Ctrl+Alt+Page  suivante pour  passer  au  commentaire  suivant  ou  sur  les  touches
Ctrl+Alt+Page précédente pour revenir au commentaire précédent.

Créer un lien vers une autre partie du document

Dans un document, si vous faites référence à une autre partie du même document, les références
peuvent  facilement  devenir  inexactes  si  vous  réorganisez  l'ordre  des  chapitres,  ajoutez  ou
supprimez  des  éléments,  etc.  Que  vos  références  redirigent  vers  le  même  document  ou  un
document externe, Writer propose deux manières de vous assurer qu'elles seront mises à jour :

• les hyperliens,

• les renvois.

Quelle que soit la méthode utilisée, si vous faites Ctrl+clic sur le lien, vous serez redirigé vers la
cible dudit lien. Ces deux méthodes ont toutefois des différences majeures :

• Le texte d'un hyperlien n'est pas mis à jour automatiquement si vous modifiez le texte de
l'élément ciblé (à moins que vous ne le modifiiez manuellement). Le texte d'un renvoi est
actualisé.

• Si vous recourez à un hyperlien, le choix des cibles sera limité (tableaux, cadres, images,
objets OLE, sections, titres, repères de texte). Vous n'aurez pas la possibilité de lui choisir
une  cible  précise  (par  exemple,  une  page  en  particulier  dans  le  document  ciblé).  En
utilisant un renvoi, vous aurez bien plus de possibilités.

• Pour  créer  un  hyperlien  vers  un  objet  (une  image,  par  exemple)  qui  afficherait  une
information  explicite  telle  que  "Figure  6",  vous  devez  modifier  le  nom  par  défaut
("Images6") en celui qui sera visible dans le document. Il vous est également possible de
recourir à la boîte de dialogue Hyperlien pour modifier le texte visible dans le document.
En revanche, les renvois vers des images contenant des légendes automatiques affichent
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directement un texte explicite. Et si ce dernier ne vous convient pas, vous avez le choix
entre plusieurs variantes.

• Si vous sauvegardez un document Writer  en HTML, les hyperliens demeureront  actifs,
mais  pas  les  renvois  automatiques.  Par  contre,  tant  les  hyperliens  que  les  renvois
automatiques resteront actifs si le document est exporté au format PDF.

Utiliser les renvois
Pour vous assurer que les références de votre document seront mises à jour si, par exemple, vous
renommez  un  titre  ou  la  légende  d'une  figure,  utilisez  les  renvois  automatiques.  Pour  plus
d'informations, référez-vous au chapitre 14, Travailler avec les champs, de ce guide.

Utiliser les repères de texte
Les repères de texte sont répertoriés dans le Navigateur et dans le champ Numéro de page de la
barre d'état. Ils sont directement accessibles en un clic de souris. Dans les documents HTML, les
repères  de  texte  sont  convertis  en  ancres  accessibles  à  l'aide  des  hyperliens.  Pour  plus
d'informations sur les repères de texte, référez-vous à la section Utiliser les repères de texte  du
chapitre 14, Travailler avec les champs, de ce guide.

Utiliser les hyperliens
Lorsque vous saisissez du texte qui peut être utilisé en tant qu'hyperlien (par exemple : l'adresse
d'un site internet ou d'un URL), appuyez sur la barre espace ou la touche Entrée pour que Writer
crée automatiquement  l'hyperlien  et  lui  applique un format  spécifique  (habituellement,  il  s'agit
d'une couleur et d'un soulignement).

Si l'hyperlien (n')est (pas) créé automatiquement, vous pouvez (dés)activer cette fonction via le
menu  Outils > Options d'AutoCorrection > Options et  en (dé)cochant  l'option  Détecter  les
URL.

Si vous ne souhaitez pas que Writer convertisse un URL spécifique en hyperlien, cliquez sur le
menu  Édition > Annuler : AutoCorrection ou appuyez sur les touches  Ctrl+Z immédiatement
après l'application du formatage.

Vous pouvez également insérer des hyperliens en utilisant le  Navigateur et la boîte de dialogue
Hyperlien. Dans cette dernière, vous pourrez modifier tous les hyperliens actifs dans le document.

Remarque

L'adressage des hyperliens peut être paramétré comme relatif ou absolu grâce à
l'option Enregistrer les URL relatifs au système de fichiers / à internet du menu
Outils > Options > Chargement/enregistrement > Général.

L'adressage relatif à un système de fichiers est uniquement possible si la source du
document et le document de référence sont tous les deux sur le même disque. La
structure du répertoire référencé n'a pas d'importance. Les fichiers seront trouvés
indépendamment de leur emplacement, aussi longtemps que la référence reste sur
le même disque.

Pour  des  raisons  de  lisibilité,  LibreOffice  affiche  des  chemins  absolus.  Par
conséquent,  lorsque vous  passez  la  souris  au-dessus  d'un  hyperlien,  l'infobulle
affiche la référence absolue même s'il s'agit d'un hyperlien relatif.

Insérer des hyperliens en utilisant le Navigateur
Le moyen le plus facile pour insérer un hyperlien vers une partie d'un document est d'utiliser le
Navigateur :

1) Ouvrez le document contenant les éléments que vous souhaitez référencer.
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2) Ouvrez  le  Navigateur (en  cliquant  sur  l'icône  dans  la  barre  d'outils,  sur  le  menu
Affichage > Navigateur ou en appuyant sur la touche F5 de votre clavier).

3) Dans le Navigateur, cliquez sur la flèche à côté de l'icône Mode glisser et cochez l'option
Insérer comme hyperlien.

4) Dans la liste située au bas du Navigateur, choisissez le document contenant l'élément que
vous souhaitez référencer.

5) Dans la liste du  Navigateur,  sélectionnez l'élément que vous souhaitez insérer en tant
qu'hyperlien.

6) Depuis le Navigateur, glissez l'élément à l'endroit du document où vous souhaitez insérer
l'hyperlien. Le nom de l'élément est inséré dans le document en tant qu'hyperlien actif.

Figure 48. Insérer un hyperlien à l'aide du Navigateur.

Insérer des hyperliens en utilisant la boîte de dialogue

Pour afficher la boîte de dialogue  Hyperlien (voir  Figure 49), cliquez sur l'icône  Hyperlien 
dans la barre d'outils  Standard ou cliquez sur le menu  Insérer > Hyperlien. Pour convertir un
texte existant en un hyperlien, sélectionnez le texte dont il est question avant d'ouvrir la boîte de
dialogue Hyperlien.

Dans  la  partie  gauche  de  la  boîte  de  dialogue  Hyperlien,  choisissez  l'un  des  quatre  types
d'hyperlien :

• Internet : une adresse web commençant habituellement par http://

• Mail & News : pour une adresse e-mail, par exemple.

• Document : cliquer sur l'hyperlien redirige vers une autre partie du même document ou
vers un autre document.

• Nouveau document : cliquer sur l'hyperlien lance la création d'un nouveau document.
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Figure 49. La boîte de dialogue Hyperlien affichant les détails pour les liens internet.

La partie  supérieure  droite  de la  boîte de dialogue  Hyperlien se modifie  en fonction du type
d'hyperlien que vous choisissez dans colonne de gauche. Une description complète de tous les
choix et de leurs interactions va au-delà des explications de ce chapitre. Par conséquent, seul un
résumé des choix les plus courants sera exposé.

Pour un hyperlien de type Internet, choisissez l'une des propositions : Web ou FTP. Saisissez ou
collez ensuite l'adresse internet (URL) requise.

Pour un hyperlien de type Mails & News (ou bien Courriels & Forums), spécifiez s'il s'agit d'un
lien vers une adresse E-mail ou d'un lien dirigeant vers un groupe de News (forum).

Pour  un hyperlien de type  Document,  indiquez dans le  champ  Chemin l'emplacement  où se
trouve le document (le bouton Ouvrir un fichier permet d'ouvrir le navigateur de fichiers). Laissez
toutefois le champ Chemin vide si vous ciblez une autre partie du document actif (par exemple :
un renvoi vers un tableau). Dans ce cas, cliquez sur le bouton  Cible dans le document pour
ouvrir le Navigateur où vous pourrez sélectionner la cible. Si vous connaissez le nom de la cible,
vous pouvez la saisir directement dans le champ Cible.

Pour un hyperlien de type Nouveau document, déterminez si le nouveau document créé doit être
édité  immédiatement  (Éditer  maintenant) ou  simplement  créé  (Éditer  plus  tard).  Indiquez
également le type du document à créer (texte, classeur, présentation, dessin ou autre). Le bouton
Sélectionner un chemin permet de choisir l'emplacement où sera enregistré le document créé
avec le nom que vous aurez déterminé dans le champ Fichier.

La section  Paramètres supplémentaires,  située dans la partie inférieure droite de la boîte de
dialogue Hyperlien, est commune à tous les hyperliens. À noter que certains choix correspondent
plus à certains types de liens.

• Cadre. Paramétrez la valeur afin de déterminer la façon dont l'hyperlien s'ouvrira. Cette
fonction s'applique aux documents qui s'ouvrent dans un navigateur internet.

• Formulaire. Spécifiez si le lien sera présenté sous la forme de texte ou d'un bouton.

• Texte. Spécifiez le texte que l'utilisateur verra.

• Nom. Champ applicable aux documents HTML. Il spécifie le texte qui sera ajouté comme
l'attribut NAME dans le code HTML de l'hyperlien.
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• Événements.  Ce  bouton  sera  activé  pour  permettre  à  LibreOffice  de  réagir  aux
événements pour lesquels l'utilisateur a écrit  du code (macro).  Cette fonction n'est pas
abordée dans ce guide.

Éditer des hyperliens
Pour éditer un hyperlien, cliquez n'importe où dans le texte contenant l'hyperlien. Ensuite, ouvrez
la boîte de dialogue Hyperlien en cliquant sur l'icône Hyperlien de la barre d'outils Standard ou
en cliquant sur Édition > Hyperlien dans la barre des menus. Il est également possible d'ouvrir la
boîte de dialogue Hyperlien en effectuant un clic droit sur l'hyperlien puis en cliquant sur Éditer
l'hyperlien dans  le  menu  contextuel. Effectuez  vos  changements  et  cliquez  sur  le  bouton
Appliquer pour les valider. Si vous avez besoin d'éditer plusieurs hyperliens, vous pouvez quitter
la boîte de dialogue Hyperliens une fois que vous les avez tous modifiés. Veillez seulement à bien
cliquer sur le bouton Appliquer pour chaque hyperlien. Lorsque vous avez terminé, cliquez sur le
bouton Fermer.

Par  défaut,  LibreOffice  permet  de  suivre  les  hyperliens  en  utilisant  la  combinaison  Ctrl+clic
gauche.  Ce  comportement  peut  être  modifié  via  le  menu  Outils >  Options  >  LibreOffice  >
Sécurité > Options. Il suffit de décocher l'option Clic en maintenant la touche Ctrl requis pour
suivre un hyperlien. Si un simple clic suffit pour activer vos hyperliens, vérifiez si cette option est
bien décochée. Il est conseillé à l'utilisateur de conserver les options par défaut pour des raisons
de sécurité (déclenchement non intentionnel).

Pour changer la couleur des hyperliens, cliquez sur le menu  Outils > Options > LibreOffice >
Apparence. Recherchez dans la liste de gauche les options Liens non visités et Liens visités.
Cochez-les, choisissez la nouvelle couleur puis cliquez sur le bouton OK pour valider votre choix.
À  noter  que  cette  modification  de  couleur  sera  valable  pour  tous  les  hyperliens  de  tous  les
modules de LibreOffice.

Dans les modules Writer et Calc, vous pouvez également modifier le style de caractère pour les
liens internet ou bien définir et appliquer de nouveaux styles aux liens sélectionnés. Ces options
ne sont pas disponibles pour les modules Draw ou Impress.

Basculer entre le mode Insérer et le mode Écraser 
En mode Insérer, le texte situé après le curseur se décale pour laisser l'espace au texte que vous
tapez. En mode Écraser, le texte situé après le curseur est remplacé par le texte que vous tapez.
Seul le mode Écraser est indiqué dans la barre d'état, mais l'aspect du curseur n'est pas modifié
lorsque celui-ci est actif.

À l'aide du clavier, appuyez sur la touche Insertion pour basculer entre le mode Insérer et le mode
Écraser. À l'aide de la souris, cliquez dans la zone de la barre d'état qui vous informe sur le mode
de frappe afin de basculer vers l'autre mode. À noter que le mode Écraser ne peut être utilisé si
l'option Édition > Modifications > Enregistrer est activée.
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Figure 50. Mode Insérer 
et mode Écraser.



Compter les mots d'une sélection
Le  Compteur de mots du document (ou de la sélection) est affiché dans la  barre d'état. Vous
pouvez mieux visualiser le  nombre de mots et  de caractère en cliquant sur le menu Outils >
Statistiques ou  en  double-cliquant  sur  le  Compteur  de  mots dans  la  barre  d'état.  Ces
informations sont mises à jour lorsque vous éditez le document.

Vous pouvez également obtenir des informations sur le nombre de mots et de caractères (ainsi
que d'autres informations comme le nombre de pages, de tableaux ou d'objets) contenus dans le
document via le menu Fichier > Propriétés > Statistiques.

Modifier la casse du texte sélectionné
Pour modifier rapidement la casse d'un texte, sélectionnez-le, puis cliquez sur le menu Format >
Modifier la casse ou faites un clic droit sur la sélection. Choisissez ensuite l'une des possibilités
suivantes :

• Casse de phrase pour que seule la première lettre du premier mot de la phrase (en plus
des noms propres) soit en majuscule ;

• minuscule pour qu'aucun mot (sauf les noms propres) ne soit écrit en majuscule ;

• MAJUSCULES pour que toutes les lettres soient écrites en majuscules ;

• Majuscule À Chaque Mot pour que la première lettre de chaque mot du texte sélectionné
soit en majuscule ;

• bASCULER LA CASSE pour que chaque lettre soit écrite dans la casse opposée.

D'autres  options  sont  disponibles  uniquement  lorsque  la  prise  en  charge  pour  les  langues
asiatiques est activée. Dans ce cas, il ne s'agit pas vraiment de modification de la casse, mais
plutôt de remplacer les caractères par des formes légèrement différentes des mêmes lettres.

Writer ne peut pas définir automatiquement la casse Majuscule À Chaque Mot lorsque tous les
mots  sont  écrits  en  majuscules.  Par  conséquent,  si  vous  remettez  ces  mots  capitalisés  en
minuscules,  vous  devrez  probablement  appliquer  la  fonction  Majuscule  À Chaque  Mot sur
certains mots afin de rétablir leur capitale.
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